3

I have just updated from 12.04 to 14.04 and now have difficulty setting up Apache 2.4 I am getting the following error:

Setting up apache2 (2.4.10-1+deb.sury.org~trusty+1) ...
ERROR: Module mpm_prefork is enabled - cannot proceed due to conflicts. It needs to be disabled first!
dpkg: error processing package apache2 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 apache2
E: Sub-process /usr/bin/dpkg returned an error code (1)

How can I disable the mpm_prefork so that Apache can continue?

5

I would use the proper command to disable a mod in Apache:

sudo a2dismod mpm_prefork
2

You should try to remove the symlinks /etc/apache2/mods-enabled/mpm_prefork.{conf,load}:

rm /etc/apache2/mods-enabled/mpm_prefork.{conf,load}

Then relaunch the configuration of the apache2 package:

apt-get install -f

Or:

apt-get install apache2

But more important, you should ask yourself how these were installed there before hand. You might have copied an older /etc/apache2 directory with these (for instance) before launching apt-get install apache2.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.