5

I have just installed phpstorm, phpstorm can be opened via command line but I can't open the program via launcher or desktop shortcut and nothing error shown.

- My phpstorm.desktop code :

[Desktop Entry]
Name=Phpstorm
Exec=/home/mockie/softwares/PhpStorm-133.982/bin/phpstorm.sh
Terminal=true
Type=Application

- For launcher shortcut, I created it through phpstorm menu

Tools > create desktop entry

Still no luck, the launcher failed to open the program.

- This is how I run program via terminal :

/home/mockie/softwares/PhpStorm-133.982/bin/phpstorm.sh

- Fyi: if I run it via command line, I got this deprecate message :

Java HotSpot(TM) Server VM warning: ignoring option MaxPermSize=250m; support was removed in 8.0

But phpstorm still can be opened successfully.

- I installed JRE on :

/home/mockie/softwares/jre1.8.0_20

5
  • The shortcut probably points to the wrong file. Could you include the shortcut file in the question? – Moose Sep 26 '14 at 8:11
  • sure @devGeek, I just edited my question :) – mockie Sep 26 '14 at 8:26
  • Does double clicking the icon even open terminal? And just to confirm, other desktop shortcuts still work right? – Moose Sep 26 '14 at 8:36
  • I haven't other shortcut except this. Terminal only open fleeting. – mockie Sep 26 '14 at 8:42
  • 1
    If I open via launcher it's only blinking and nothing happened. Is there any log to see this kind of error ? – mockie Sep 26 '14 at 8:44
2

I don't know if you ever got this to work, but the issue I'm almost certain was this:

The command you are executing should be:

/bin/bash /home/mockie/softwares/PhpStorm-133.982/bin/phpstorm.sh
1


I think you are missing about permission. So, you can make it executable:

 cd /home/mockie/softwares/PhpStorm-133.982/bin
 chmod +x phpstorm.sh

Then, try create launcher again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.