1

I have installed Ubuntu Server 14.04.1 on VirtualBox. With LAMP all configured. The box has static ip 192.168.1.104 and bridged to my host's Wireless adapter. I can successfully access Apache's index page from my home's local network.

Setup port forwarding on my router to port 80 of this server. However, it gives me timeout error when I browse using my public ip or Dynamic DNS name. Note: Port forwarding on my router succeeded to connect my Windows PC's Apache, as well as Arduino server.

Here is nmap localhost results:

Starting Nmap 6.40 ( http://nmap.org ) at 2014-09-25 23:04 EEST
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00044s latency).
Other addresses for localhost (not scanned): 127.0.0.1
rDNS record for 127.0.0.1: userver
Not shown: 986 closed ports
PORT      STATE SERVICE
21/tcp    open  ftp
22/tcp    open  ssh
25/tcp    open  smtp
53/tcp    open  domain
80/tcp    open  http
110/tcp   open  pop3
139/tcp   open  netbios-ssn
143/tcp   open  imap
443/tcp   open  https
445/tcp   open  microsoft-ds
993/tcp   open  imaps
995/tcp   open  pop3s
3306/tcp  open  mysql
10000/tcp open  snet-sensor-mgmt

Nmap done: 1 IP address (1 host up) scanned in 0.12 seconds

Any help to get my ubuntu reachable to internet is appreciated!

  • Can we assume you really meant: 14.04.1 ? – david6 Sep 28 '14 at 0:21
  • 1
    Sorry, you are right @david6, I will edit it right now . – assem Sep 29 '14 at 6:23
0

I ran into this same exact problem a while ago. After spending way too much time troubleshooting and trying to figure out why it wouldn't work, I found out it was not a problem with my configuration.

Most of the time, your ISP (internet service provider) blocks calls to port 80. (Example: List of ports blocked by Cox)

This means that although you are redirecting calls to port 80 to your machine, they are never actually receiving those calls to begin with.

Try to google your ISP and see if they block any ports. Then try forwarding to a port they don't block, and append that port to the url. (Example: forward to port 1234, do http:// your ip:1234). If that works, but port 80 doesn't then that is the problem.

  • In fact, port 80 is open for my ISP. When I browse to my public ip without any port forwarding set, it points to my router's index page. and I've succeeded to forward port 80 to my Windows Apache port 80. So I don't think it's my ISP's port 80 issue! – assem Sep 26 '14 at 7:40
  • Ah, I missed that detail, sorry. If it is your virtual machine, check the network type, it is possible that virtual box isn't configured to forward those ports. Check this article – Steven Jeffries Sep 26 '14 at 8:06
  • Well, I was setting networking type for VM to Bridged Adapter, so the VM holds it's own IP address through the network. I have no previous experience with NAT settings. But, I've changed it to NAT, and set VM port forwarding from host. and it worked :) However I am not familiar with the IP form in ifconfig (not like 192.168.1.x). I'm curious if I can do that with Bridged Adapter mode. – assem Sep 26 '14 at 13:27
  • please edit your answer or answer another stating using NAT with port forwarding of VirtualBox So I will set it as an Accepted answer. – assem Sep 26 '14 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.