1

I just installed Ubuntu 14.04, and when I try to add "Weekday" or "Date and month" to my clock, the entire clock disappears (though, oddly this does not happen when I add "Seconds"). I tried to uninstall and reinstall indicator.datetime, but no luck. Any tips?

Before: (http://i.imgur.com/3u2c4f5.png)

After: (http://i.imgur.com/u7Ack3D.png)

  • Have you tried relogging after the change ? – MrVaykadji Sep 25 '14 at 20:08
  • I should have clarified, but yes, I have. – pianocargo Sep 25 '14 at 20:17
  • It might not be very helpful, but it works for me x) So it might be a random issue, or a conflict? Can't do much more for you, sorry. Other may! – MrVaykadji Sep 25 '14 at 21:13
  • There is another question with some answers that you might try: askubuntu.com/questions/458117/… – Martin Dirichs Sep 28 '14 at 16:00
1

Ok, install dconf:

sudo apt-get install dconf-editor

open dconf under com>canonical>indicator>datetime:

and uncheck and check " show-clock ".

logout and login.

enter image description here

| improve this answer | |
0

I could solve this problem by

  1. deleting the /etc/locale.conf
  2. Going to Settings -> Language Support -> Regional Formats; choose a format; and 'Apply System-Wide'
  3. reboot

Background: The problem appeared when I changed my locale settings globally in /etc/locale.conf instead of locally in .bashrc. A post on Missing date & time from top panel of Unity Desktop - Ubuntu 14.04 pointed to 'Settings -> Language Support'. But only installing the missing regional formats was not enough.

| improve this answer | |
0

In my case I need to comment out (remove) line export LC_ALL=C in /etc/environment.

  1. Logout
  2. Login
  3. Enable weekend/date in clock settings
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.