lubuntu 14.04 sensors output follows... why it says ALARM-CRIT when it's well within range?

Adapter: ISA adapter
Core 0:       +79.0°C  (high = +84.0°C, crit = +100.0°C)  ALARM (CRIT)
Core 1:       +79.0°C  (high = +84.0°C, crit = +100.0°C)
Core 2:       +71.0°C  (high = +84.0°C, crit = +100.0°C)
Core 3:       +69.0°C  (high = +84.0°C, crit = +100.0°C)
Adapter: PCI adapter
temp1:        +66.5°C  

why it says ALARM-CRIT when it's well within range?

I bring this up because came across it trying to figure out why my fan runs all the time - another annoyance - is it because of the misperceived ALARM above? How can I fix both of these issues? Mainly fix the fan from running all the time & fix this misperceived ALARM - or if it's the root cause for the fan hopefully fix both at once.

Also another item - my lockscreen defaults away from my set resolution on main screen to the std default of 1920 by 1080 - how can I fix this to match main screen 1280x960?


  • Which model is your laptop? And which programme are you using to control the fan, if any? – GMZ Sep 26 '14 at 0:21
  • its a desktop - powerspec b900 - not using any program to control the fan. Per trying self help from various articles I added sensors above and tried to add fancontrol but it failed to install - also failed to run something called pwmconfig - it said wasn't available to run when I attempted to run it. Was trying this article & then realized it was from 2008.... tuxtweaks.com/2008/08/how-to-control-fan-speeds-in-ubuntu/ – brwntree Sep 28 '14 at 18:55
  • just some more history of cmds I ran in case it helps... – brwntree Sep 28 '14 at 19:33
  • B900:~$ sudo apt-get install fancontrol The following packages were automatically installed and are no longer required: linux-headers-3.13.0-24 linux-headers-3.13.0-24-generic linux-image-3.13.0-24-generic linux-image-extra-3.13.0-24-generic Use 'apt-get autoremove' to remove them. The following NEW packages will be installed: fancontrol ... .... Setting up fancontrol (1:3.3.4-2ubuntu1) ... * Not starting fancontrol; run pwmconfig first. Processing triggers for ureadahead (0.100.0-16) ... – brwntree Sep 28 '14 at 19:34
  • B900:~$ sudo pwmconfig # pwmconfig revision 6166 (2013-05-01) This program will search your sensors for pulse width modulation (pwm) controls, and test each one to see if it controls a fan on your motherboard. Note that many motherboards do not have pwm circuitry installed, even if your sensor chip supports pwm. We will attempt to briefly stop each fan using the pwm controls. The prgm will try to restore each fan to full speed after test. However, its important that fans are full speed after test completed. /usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed – brwntree Sep 28 '14 at 19:37

This happened to my friends laptop as well. You have two options;

1) Ensure that you have all the additional drivers installed on your laptop, you can do this by accessing system settings > Additional drivers.

2) You can access your BIOS screen on boot up, and change the temperature at which the alarm will go off, or depending on your laptop series, you could also set the temperature at which the laptop should start spinning the fan or setting off the alarm.

The second part of the second step should be approached and executed with caution because then you may fry your laptop, so i would recommend setting the temperature at which it alarms or starts to spin the fan +1/2 degrees Celcius.

  • Thx for the help & tips. – brwntree Oct 1 '14 at 15:58

I agree with the previous answer: the best thing to do is update your drivers.

About changing the temperature settings via BIOS, verify on the cpu maker datasheet if you can safely run the processors at higher temp.

In addition to that, you showed that core0 and core1 are very close to the critical temp, so even with minor activities the fan kicks in. Verify that the area around this cpus is clean and that no dust is clogging the fan. This is normally the first cause for high temp.

If you built the computer yourself OR if you removed the fan/heatsink around that area, you may have a problem with the thermal compound. Get a good paste on the web (ph1, noctua, etc), remove old compound and apply new one.

I hope this helps

  • 1
    yes, thx - seems the AMD drivers install did help some but there are no other drivers to install. My sensors output actually shows it below the "high" marker (also the OP shows not in the high range) - here's another output... Core 0: +79.0°C (high = +84.0°C, crit = +100.0°C) Core 1: +79.0°C (high = +84.0°C, crit = +100.0°C) Core 2: +71.0°C (high = +84.0°C, crit = +100.0°C) Core 3: +68.0°C (high = +84.0°C, crit = +100.0°C) – brwntree Oct 1 '14 at 15:47
  • Output seems to be OK... Check the temp as soon as the fan starts. If it is above high level, that's the normal behaviour of the fan. Noisy, but needed. If the fan starts when not needed, must be a setting somewhere that gives the wrong start/stop temperature – GMZ Oct 1 '14 at 15:56
  • Since 79 may be considered high (even though it's below the 84 high marker) it may be sensible that some occasional fan over speed bursts are deemed necessary by the new drivers is possible. I always check for & remove dust but will again anyway. Didn't remove any heat supporting items. A point of interest though is this ran U_12.04 for many years & never had this same fan behavior. Thx again for the help & tips. – brwntree Oct 1 '14 at 15:57
  • m.webupd8.org/2013/04/…. You may want to try this power management app. Apparently Ubuntu 14.04 is more resource consuming than 12.04. I am facing similar problems with lubuntu and had to adjust my fan settings. I'll try this app myself very soon :) – GMZ Oct 2 '14 at 10:25
  • TLP - would also like to try it at some time - just not sure if it can used for a desktop as it seems to only be for laptops. – brwntree Oct 25 '14 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.