I'm unable to mount Sandisk 64GB SDXC card.

This error shown while connecting using my phone.


I tried this, this and this links, but unable to find any solution.

I've tried the below commands to install the exfat,

sudo add-apt-repository ppa:relan/exfat
sudo apt-get update && sudo apt-get install exfat-utils fuse-exfat

But below error displayed in terminal,

The following information may help to resolve the situation:

The following packages have unmet dependencies:
fuse-exfat : Depends: fuse-utils (>= 2.7) but it is not installable
E: Unable to correct problems, you have held broken packages.

1 Answer 1


There is no need to add extra repo. If you are using Ubuntu 14.04, exfat-fuse and exfat-utils packages are present in Universe repository.

Enable it (if it is not enabled) using

sudo add-apt-repository universe

Update your software list using

sudo apt-get update

Now you can install it using

  sudo apt-get install exfat-fuse exfat-utils
  • Thanks for the answer. But is it the fuse-exfat or exfat-fuse?
    – Karthik
    Sep 25, 2014 at 19:06
  • 1
    It is exfat-fuse.
    – g_p
    Sep 25, 2014 at 19:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .