I am having an issue with Ubuntu. I am running the latest version under Oracles VirtualBox. The highest resolution it will accept is 1600x1200.

I have a new Samsung 28" UHD 4k display. I need to run this in fullscreen. So I would like to at least get 1080p out of it.

Are there any workarounds?

Also, I have 3d acceleration enabled but when I move my cursor it is very laggy, spikes so to speak.

Thanks kindly.

  • Hmmm this will not be related to Ubuntu but with vBox. Please refer to the user manual section 9.8.2 for screen resolutions.
    – Rinzwind
    Sep 25, 2014 at 13:41
  • I can't get that to work properly. In command prompt/terminal it says no such thing exists. Sep 25, 2014 at 15:14
  • 1
    You need to install the guest additions.
    – dobey
    Dec 15, 2016 at 20:53
  • 1
    See How do I install Guest Additions in a VirtualBox VM? and enable graphics acceleration in the display settings. Dec 22, 2016 at 14:54
  • 1
    You may need to increase video memory as well..
    – Elder Geek
    Dec 22, 2016 at 16:31

2 Answers 2


1: Video Memory

I got a message saying that my gues needed at least 33MB (or something) of video memory. I set it to 64MB and I could select my full 4K resolution.

2: Scaling factor

Not relevant to Ubuntu most likely, but just adding it here in case someone stumbles on this post from Google
Something else that may be affecting this is the scaling factor in Windows 10.
If this is set to 150% your guest resolution will also be scaled and you won't be able to select the full 4K resolution in the client causing everything to look slightly blurry.
You can set this to back 100%, which will make everything work as expected again.
Or if you want to keep the 150% scaling in Windows but not your guest, you can check out this post. (setting guest resolution through command line)
Haven't tried that myself though.


I'm going to ask the obvious, but have you install the VBoxAdditions?

On the main menu if you click

Devices -> Install Guest Additions CD Image

It may or may not auto prompt the install, but after it should work.

My build is current running at 3840x2009 (not 2160 because of my main OS menu bar and the VM wrapped borders)

Hope this helps!

Not the answer you're looking for? Browse other questions tagged or ask your own question.