I have installed Lubuntu on an old Dell D600 laptop. Everything is working great except for the wireless Ethernet card.

"lspci -vnn -d 14e4:" reveals the following:


Broadcom Corporation BCM4309 802.11abg Wireless Network Controller [14e4:4324] (rev 02)


Somebody recently (Sept 5th) posted the answer for a card very similar to this (all the same except for the "rev 02" part) - and in their answer they stated something similar to "You have a 50% chance of having the other (rev 02) version of this wireless card - if it turns out you have that one, post back again for recommendations relevant to that".

Apparently the other question-asker did not have the "rev 02" version, as they did not post back again.

I'm hoping either the person posting that answer or somebody else here could post their recommendations for the "rev 02" version of this card.


  • Please add a link to the question you're referring to – Jan Sep 25 '14 at 12:15

I got it working. I found the "final solution" at this page:

Installing Broadcom Wireless Drivers

Following those instructions, I found that I needed to install a package called "linux-firmware-nonfree", followed by a reboot.

After installing that, wlan0 finally began showing up on "iwconfig" (previously only eth0 and lo were showing).

I did still have one problem - apparently the radio was shut off via the hardware button (on this model it's "Fn-F2" to toggle on/off - for some reason the little blue wireless LED is not working any longer, which usually gives an easy visual indicator about the radio state).

I discovered that part when I tried to bounce the wireless card with "sudo ifconfig wlan0 down" followed by "sudo ifconfig wlan0 up" - the second command resulted in "operation not possible due to RF-kill".

So, I ran "sudo rfkill list all" which showed "Hard Blocked: yes" (this means the radio is physically turned off). I hit Fn-F2 and ran it again - now "Hard Blocked" was changed to "No".

From that point in GNome Network Manager I already had the option to pick my network SSID and enter my WPA passphrase - all is well, I am up and running on wireless.

Thanks to everybody!

  • I didn't see anything in the other page about the linux-firmware-nonfree package. This seems to have solved my problem. Thanks! – intuited Dec 9 '15 at 15:44

The Dell D600 series is probably my all-time favorite laptop. I have several in various states of disrepair, the newest being a 610. Years ago I actually had difficulty making the included Broadcom mini PCI cards in them work and had to replace them with Intel mini PCI cards. In recent years it appears Linux has supported all the Broadcom cards I've thrown at it, although if I recall correctly there's a minor trick to it. You have to connect the computer to the internet using an ethernet cable and then do a system update to give it the opportunity to automatically download the correct drivers.

If after doing that it still doesn't work, I'd advise you do what I've done to install drivers for lesser-recognized wireless devices. I (install and) open the Synaptic Package Manager, and then search for what I'm looking for. Looking at it now on your behalf and using the search parameters "broadcom bcm" (without quotes), I see only four choices with the most promising possibly being "b43-fwcutter".

  • Thank you. Yes, I already have "b43-fwcutter" installed as well as "firmware-b43-installer" (based on another recommendation I read that stated these cards have some 'on-chip firmware' that needs to be run, and supposedly this firmware package loads that - however, it has had no effect). – Michael Anderson Sep 26 '14 at 0:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.