I'm trying to stop my Ubuntu desktop from automatically mounting my iPhone when I connect it/plug it in. This causes my Vmware workstation to not mount the iphone for syncing.

I have used gconf-editor and disabled the automount option yet I'm still seeing my iPhone after reboot:

tim@Tim-on-Linux64:~$ lsusb
Bus 002 Device 011: ID 05ac:1297 Apple, Inc.

Any help would be appreciated...


So far the only way I've seen to not automount external devices is:

  1. Open up the terminal and type in:

  2. Scroll down to Nautilus -> Preferences -> Media Automount

  3. Uncheck the option for Media Automount

I tested after unchecking the Media Automount option without a system restart and it did not automatically mount my iPod but it was still listed under Places -> iPod and available for mounting which equals success.

I then un-mounted the iPod, restarted the system, and plugged my iPod back into the system. Once again it did not automatically mount and also once again was under Places -> iPod and available to be mounted.

I don't know if it is just a fluke or a bug you have but using gconf-editor worked for me so I'll suggest maybe you give it another shot?

  • I tried your suggestion again. No joy. Here is there error vmware is giving me:
    – TJ_IN_AK
    Jul 13 '11 at 1:02
  • Uhm, you said it's giving you an error but you didn't display what that error is... Pastebin it?
    – zkriesse
    Jul 13 '11 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.