1

I have mounted a partition as ext4 and define in /etc/fstab.

UUID=4xxxxxx-xxxxx /wdd ext4    defaults 0  2

I can see the mount point as /wdd running df -k.

But it is not showing up as device under Nautilus. I wish it is found there. I search and found a post saying that I need to mount under /media. I do not want to mount under /media. Is there a way there?

  • Yes. Use Nemo. – muru Sep 25 '14 at 4:45
1

You could add it as a bookmark. Just add the line file:///wdd to file ~/.config/gtk-3.0/bookmarks. For more details see How to add bookmark to Nautilus 3.6?

  • It worked!. Thanks for the workaround. Can know the rational behind why it is not showing under devices? – Haans Sep 25 '14 at 6:02
  • I guess because you added it to fstab so it is not a hot-pluggable device any more. If you want to experiment remove it from there and reboot. You should see it in devices but it will not be mounted automatically. Click on it to mount it then create a symlink /wdd pointing to /media/<user>/4xxxxx. It is not quite the same (no automount) but you will see it in Devices. – sмurf Sep 25 '14 at 7:07
1

Another approach is to mount it under /media and make /wdd a link to the mount point. Make your fstab like this:

UUID=4xxxxxx-xxxxx /media/wdd ext4    defaults 0  2

Then, remove the existing /wdd directory and recreate it as a link:

sudo rmdir /wdd; sudo ln -s /media/wdd/ /wdd

You can also try the reverse approach but I;m not sure if nautilus will pick it up:

sudo ln -s /wdd /media/wdd
  • 1
    That worked like a charm! I am seeing the drive appearing under devices as soon as I mount it as /media/wdd. – Haans Sep 25 '14 at 12:47
  • @haans glad to hear it! If one of these answers solves your issue please take a minute and click the check mark under the vote count to the left, this will signify to everyone that your issue's been resolved. – terdon Sep 25 '14 at 12:51
  • Tried the reverse approach. Didn't work. I just used what Smurf suggested. – jcora Oct 19 '14 at 0:34
0

I realize this question is a bit old, but it's coming up as a top google search. By default Nautilus/Caja automatically show devices mounted in/media. This policy may be overriden by use of the options x-gvfs-show. So your fstab entry would look like:

UUID=4xxxxxx-xxxxx /wdd ext4    defaults,x-gvfs-show 0  2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.