1

Sound was working on my laptop last night. I turned it off, and when I turned it back on this morning, sound no longer worked. I've tried various pulseaudio related solutions that I found here, including:

All of those have not restored my sound (though I have succeed in eliminating the pulseaudio icon in my icon tray, and get no graphic when I press the volume button on my keyboard). Other posts on sound seem to suggest the same as above. Any other ideas?

By the way, it is not a hardware issue. I have a (rarely used) windows install, and sound works there fine.

Edit: I forgot to mention that I had looked at alsamixer to see if anything was muted. I am not familiar with this utility, so I had simply looked before for the "MM" denoting mute. From seeing more examples, it looks like there is something wrong here. AlsaMixer screenshot

Edit 2: And the output from alsa info is here: http://www.alsa-project.org/db/?f=3b51070b87416733947444b9c8c25a203d9d6507

Edit 3: The output from speaker-test:

speaker-test 1.0.27.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory
2

Various actions or tests:

  • Do software update, reboot ,
  • Carefully check Alsa layer volume running alsamixer in a maximized terminal : using arrow keys, and eventually F6 to select main (non-hdmi) soundcard : increase level in "master" and "pcm" fader , press "m" key 2 or 3 times to toggle their mute state (even if they seem not muted).

  • If not ok, disable pulseaudio to test in alsa only mode:
    mkdir ~/.pulse
    echo autospawn=no > ~/.pulse/client.conf
    then reboot .
    Then your are in Alsa only mode: test your audio (pulseaudio volume applet will be offline, use alsamixer or gnome-alsamixer to set volume).
    Most Linux software can output audio directly to Alsa without using pulseaudio (exception is Skype, but ok for Firefox and flash player ,vlc etc....)
    A good test is running "speaker-test" in a terminal : you should hear pink noise.

If stills bad , run "Alsa-info" to show your audio config (someone can have an idea) : copy the following command in a terminal , choose "upload" option when asked ("tab" key to select it) an post url printed at the end.
wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh

  • When alsa test is finished and running ok, to revert to pulseaudio mode, run:
    echo autospawn=yes > ~/.pulse/client.conf
    and reboot (or run "pulseaudio" in a terminal that you keep open) .
    If Alsa test was ok and Pulseaudio doesn't work, reset again pulseaudio config like explained in the other threads
  • Thanks for the suggestions. I had tried disabling pulseaudio. I'm guessing that's why my icon disappeared. It seems like there is something weird about my alsamixer output. I added a screenshot, plus the link to alsa-info output. – jdmcbr Sep 25 '14 at 16:39
  • Your alsamixer is showing hdmi audio: press F6 function key and use arrow keys to select the main (hda intel) soundcard, you will see more faders. – laugeo Sep 25 '14 at 19:02
  • Use "up" arrow key to increase volume on the first "master" fader which is a bit low (from your alsa-info), try also tweaking other faders (well they seem ok from alsa-info) – laugeo Sep 25 '14 at 19:11
  • Oh, oops. I adjusted the volume as suggested. I then tried the speaker-test. That gave an error, which is shown above. I hadn't seen that before, so I'll look around to see if fixing that solves the rest of my sound issues. – jdmcbr Sep 25 '14 at 19:21
  • 3
    With no guarantee, test changing sound cards order by editing /etc/modprobe.d/alsa-base.conf : run sudo gedit /etc/modprobe.d/alsa-base.conf then add 2 line at the file end : options snd-hda-intel index=0 model=auto vid=8086 pid=9c20 and options snd-hda-intel index=1 model=auto vid=8086 pid=0a0c then save file and reboot – laugeo Sep 27 '14 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.