2

so I have a strange problem. I'm currently using an old Thinkpad T61 and Ubuntu 14.04 LTS, although this same problem was also happening when I had elementary OS Luna (based on ubuntu 12.04 LTS)

Image:

As you can see in the picture the CPU usage varies in a sort of waveform, getting 100 % load pikes each few seconds.

So I've been a lot of time trying to find out the cause of the problem, here in these forums I found this post: Why does kworker cpu usage get so high?

I followed everything said on the replies, when I did this:

grep . -r /sys/firmware/acpi/interrupts/

I found out that the gpe12 had a really high number so I followed instructions to try to disable it. The problem was still there.

I tried another bunch of things. Actually right now there is no /sys/firmware/acpi/interrupts/ (I've tried so many things I cant remember how this happened, probably disabling the acpi in the grub options?)

So now, I don't really think It can be solved, so maybe another type of solution could be to install some older Ubuntu version with an older kernel? (Something from the late 2000s) or maybe downgrading the kernel (not really sure about if this is safe or possible for this version)

Also, I have a windows partition installed, would it be deleted if I uninstall my linux partition?

Thanks in advance and sorry if I made dumb questions, but I've been many days trying to solve this and its driving me crazy.

  • Neat! /me takes photo – Kaz Wolfe Sep 25 '14 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.