I'm trying to install ubuntu on a new T440p laptop from Lenovo and it always fails for the same reason:

[ 135.292409] SQUASHFS error: sb_bread failed reading block 0x9d7f3
[ 135.292411] SQUASHFS error: Unable to read fragment cache block [275faa28]
[ 135.292413] SQUASHFS error: Unable to read page, block 275faa28, size 23a7

I downloaded the newest Ubuntu (Ubuntu 14.04.1 LTS 64 bit), and now tried with every USB stick that I have, that has over 1GB of space, and no one works!

I checked the .iso file hash with HashCalc, and the hash is ok. I installed the files with Universal-USB-Installer, and that apparently worked too (I actually get the startup screen from Ubuntu, where I have to choose "start ubuntu" or "install ubuntu", etc) - but after 3 different USB sticks, and about 5 attempts, it still completly fails.

The ubuntu load screen simply loads for an eternity, and when I go to a virtual console with CTRL+ALT+F2, it shows the above error getting repeated each couple of seconds.

What can I do to solve this? Burning a CD/DVD is not possible atm, and I only have those three USB sticks to try (and it really doesn't seem like the USB sticks would be the problem).

Any Ideas?


Edit: I managed to burn a DVD now, and I still have the exact same issue! (I re-downloaded the .iso, checked it a second time, and the checksum again, seems to be ok). Even with the DVD, I'm getting:

[ 183.251602] SQUASHFS error: Unable to read fragment cache entry

and

zlib decompression failed, data probably corrupt

How is that possible?

up vote 5 down vote accepted

I managed to solve the issue for now: By pressing F6 (or, FN+F6 in my case) I could open an "extras" menu, where I had to select the option acpi=off. With that option, I was able to finally proceed the installation.

  • 1
    I get the same with 16.10, now with 17.04. Did you install it on a SSD drive? I have tried a lot of things, including your solution, but for me it did not work. For the running 16.10 I had to install the mini version and then o from the internet (created wired internet connection between 2 computers) to install it. – conualfy Apr 21 '17 at 6:10

I had a similar problem (SQUASHFS error: sb_bread failed reading block) while using USB stick to install both ubuntu 16.04 and ubuntu 17.10 on Dell Inspiron 15R. However, My problem was with USB stick and was solved by changing the USB Stick.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.