Sometimes my network manager indicator (applet) shows as if I'm not connected to wifi (no bars) and when I right click it it says "networking disabled" although I am connected to the internet. Maybe it's a bug or something.

Running sudo service network-manager restart fixes this applet. It restarts the whole network. Does anyone know a simple way to restart just the applet? (nm-applet)

  • Is there a bug in Launchpad for this issue that we can follow? I'm more interested in "curing the disease" than "treating the symptom", so to speak. – Ryan Mar 18 '17 at 18:17
  • 1
    I have the same problem in 16.04, and sudo service network-manager restart doesn't always fix it. For example, now the indicator shows zero "bars" and no network, even though I'm online typing this comment. Screenshot. – Dan Dascalescu Apr 3 '17 at 20:33
  • 1
    @DanDascalescu see the accepted answer. use killall nm-applet; nohup nm-applet & – Mina Michael Apr 3 '17 at 20:46
  • @MinaMichael Thank you for the hint about sudo service ____ restart !! – isomorphismes Jul 29 '17 at 15:32

You can restart nm-applet with this command from terminal:

killall nm-applet; nohup nm-applet &

or by restarting the network-manager service (which will restart nm-applet):

sudo systemctl restart network-manager


sudo service network-manager restart

A youtube video explaining the answer

| improve this answer | |
  • 4
    Perfect -- working on 16.04 still. – dpb May 15 '16 at 17:53
  • does the trick on 16.10 as well, fixing the not discovering new wifi on the xps 13 – Sideshowcoder Nov 8 '16 at 18:11
  • 1
    it doesn't work on 16.10. the app restarts but it does not show in taskbar. only works by restarting network-manager service. after killing nm-applet, not even restarting network manager shows it again, and I had to restart lightdm. – Zibri Dec 16 '16 at 9:42
  • Worked on 16.04.2, while sudo service network-manager restart didn't (it led to the indicator showing zero "bars" and no network, even though I'm online typing this comment. Screenshot. – Dan Dascalescu Apr 3 '17 at 20:35
  • but, how I can do the killall nm-applet && nohup nm-applet & automatically after resume ? – Yonsy Solis Jul 17 '17 at 1:54

If you have gnome, restarting the shell (Alt-F2, r, Return) might do it.

| improve this answer | |
  • Sorry it didn't work for me. Btw I stated I'm on LXDE which is not gnome – Mina Michael Sep 29 '14 at 19:07
  • I shouldn't try that when Pycharm/Chrome/A few ssh session are opened... – Youw Nov 1 '16 at 14:24

None of the accepted answer's suggestions worked for me in Ubuntu 16.04.5, but this did:

sudo killall -9 nm-applet && nm-applet &

The main difference seems to be sudo before killall.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.