-1

I have installed Stencyl on ubuntu and it is perfectly working fine from terminal commands, after making some amendments in Stencyl file. Now i want to make desktop entry for the Stencyl and wish to put the icon in the launchpad, i have prepared stencyl.desktop in /usr/share/applications/ as

[Desktop Entry]
Name=Stencyl
Type=Application
Exec=/opt/Stencyl/Stencyl
Terminal=true
Icon=/opt/Stencyl/icon.xpm
Comment=Game Development Environment
NoDisplay=false
Categories=Development;IDE
Name[en]=stencyl.desktop

and have drag and drop to the launchpad, Icon is not executing Stencyl application, if i run the same application from terminal, it is working fine and giving following results also

amulbhatia@Nadar:/opt/Stencyl$ ./Stencyl
[LOG] The Stencyl workspace is: /home/amulbhatia/
[LOG] lang/locales.txt
[LOG] Locales: {de=German, it=Italian, test=test, pt=Portuguese, fr=French, en=English, ru=Russian, gr=Greek, es=Spanish}
[LOG] Reading... global-phrases
[LOG] Bad - Line #: 98
[LOG] Finished reading lang/en/global-phrases.lang
[LOG] Reading... global-errors
[LOG] Finished reading lang/en/global-errors.lang
[LOG] Reading... global-menu
[LOG] Finished reading lang/en/global-menu.lang
[LOG] Reading... global-welcome
.
.
.

Any help in preparing desktop entry is highly appreciated

  • You should set Terminal=false as it's not a console application. Also, NoDisplay=false is not required, and Name[en] is not meant to be the file name of the .desktop file. It should also be Stencyl there (or you can just remove that line as well). – dobey Sep 24 '14 at 17:48
  • @dobey - i did the same thing, still not working.. [Desktop Entry] Name=Stencyl Type=Application Exec=~/opt/Stencyl/Stencyl Terminal=false Icon=/opt/Stencyl/icon.xpm Comment=Game Development Environment NoDisplay=false Categories=Development;IDE Name[en]=Stencyl Do you know how to execute ./file from different directory, because of this exec is not able to execute the Stencyl file (as it is executable file) – Aman Sep 24 '14 at 18:09
  • If i try to run from other directory i get this error - amulbhatia@Nadar:/usr/share/applications$ /opt/Stencyl/Stencyl Error: Unable to access jarfile ./sw.jar May be because of sw.jar the .desktop file is not executing, please help – Aman Sep 24 '14 at 18:15
  • Thanks for your time, i wrote a shell script and executed the script from .desktop file, and same is working fine from launchpad now, may be otherway, but my work has been done, thanks for your time – Aman Sep 24 '14 at 18:47
0

You need to add Path=/opt/Stencyl to the .desktop file.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.