1


I've problem with my laptop fan in Lubuntu 14.04 64bit.
(model: Fujitsu LIFEBOOK AH532) Datasheet

Fan does not work! :-(
How can I fix it? (Or how can I force enable fan?)

Some of my tries:

$ sudo sensors # After sensors-detect

acpitz-virtual-0
Adapter: Virtual device
temp1:        +59.0°C  (crit = +84.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +61.0°C  (high = +80.0°C, crit = +85.0°C)
Core 0:         +61.0°C  (high = +80.0°C, crit = +85.0°C)
Core 1:         +60.0°C  (high = +80.0°C, crit = +85.0°C)

61°C! also CPU is not busy.

$ sudo pwmconfig

# pwmconfig revision 6166 (2013-05-01)
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed


$ sudo fancontrol

Loading configuration from /etc/fancontrol ...
Error: Can't read configuration file

Thank you.

4
  • Perhaps the fan has just died?
    – corev
    Sep 24 '14 at 14:08
  • No! In Windows 8.1 I have not any problem.
    – Fadavi
    Sep 24 '14 at 14:13
  • maybe some option about fan speed/control in bios?
    – feligiotti
    Sep 24 '14 at 15:13
  • BIOS of AH532 has 2 modes for fan: Silent and Normal and my laptop is in normal mode.
    – Fadavi
    Sep 24 '14 at 15:34
2

This may work:

gksudo gedit /etc/default/grub

In the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

add at the end: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="!Windows 2012""

4
  • Thanks! I think this works! Fan is working. But sensors and pwmconfig has not any change yet! :( How can I check the fan status/RPM?
    – Fadavi
    Sep 25 '14 at 1:13
  • Please explain about reason of this solution? why adding `acpi_osi="!Windows 2012" solves this problem?
    – Fadavi
    Sep 25 '14 at 1:23
  • By adding that line, you make the bios believe that your system is windows 8 instead of linux. Many bios vendors don't support officialy linux acpi, and for so the linux kernel offers this "emulation" method to bypass the limitations. I'm sorry if I don't make much sense, I'm not an expert. About the sensors. If they didn't work with acpi=linux(default) I don't think there's going to be a way to make them work now. But you could try upgrading the bios, maybe the manufacturer added support.
    – Erdorath
    Sep 25 '14 at 7:10
  • After browsing through the forums, people suggest trying other acpi modes: acpi_osi="!Windows 2006" acpi_osi="Windows 2006" acpi_osi="Linux" acpi_osi="Windows 2001 SP2"
    – Erdorath
    Sep 25 '14 at 7:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.