2

every time I start my computer up, the English keyboard setting is active, and I have to change back to the German (Switzerland) one.

I want to keep my Computer as English as possible (e.g. English menus), but with a permanently active German (Swiss) keyboard setting.

How can I do that?

1

It is probably bug https://bugs.launchpad.net/ubuntu/+source/indicator-keyboard/+bug/1240198 or https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1246272 (Ubuntu 13.10, 14.04 and 14.10 seems plagued by a series of multi-layout keyboard bugs. See also https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1218322 which is one of the hottest bugs in launchpad).

There are a couple of workarounds that seem to work; at least they work for me. Basically you issue from a terminal

gsettings set org.freedesktop.ibus.general use-system-keyboard-layout false
gsettings set org.gnome.desktop.input-sources current 0

and then disable IBus in Settings -> Language support:

Settings -> Language support

It works for me, although you loose some function (for example, ctrl+shif+u unicode direct input).

  • Thank you, this solution works perfectly! I do not use ctrl-schift-u Unicode input anyway, so... – user258532 Sep 26 '14 at 11:54
1

Access the Dash, search for an application named "Text Entry" and start it up. In it you will be presented with a selection box entitled "Input sources to use:"; it lists all the keyboard mappings presently available in your system. In your case it is probably listing English and German (Switzerland).

You can turn the German mapping the default in two ways:

  1. using the "arrow up" button to move the German mapping to the top.

  2. using the "minus" button to remove all mappings except German.

These buttons are signalled in the image below.

enter image description here

  • I have applied this, and German (Switzerland) is already at the top of this list. But still after every boot, the English keyboard layout is active... :/ Not a big problem anyway, but it's nevertheless nagging. – user258532 Sep 26 '14 at 11:48
  • But thanks anyway for your effort! – user258532 Sep 26 '14 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.