4

I'm a bit disapointed on how keyboard and regional settings are handled by Ubuntu (14.04) for our little country, Switzerland :)

Let me explain : 3 main languages (French, German and Italian. Please no troll with Romanch), all of them with their keyboard layout, but with same regional settings (currency/date-time format/...).

The curious thing is, for finding the french keyboard layout during the installation, I've had to browse on "German (French)". For me it's kind of weird because with other OSes, I used to find it on "French (Switzerland)", or "Swiss-French KEYMAP=fr_CH-latin1". But at the end, it works, so... no offense taken.

The interesting stuff, now, is that Ubuntu seems to have interpret that I'm in Germany, because, even if the full system is displayed in english (as I wanted) and the keyboard layout is fr_CH, the weekday on the right upper corner is displayed in German...

I went then in System Settings>Language Support, and find out that English is the main language, but German is present as well. I did remove it but it didn't change anything. Then, in the same windows, on the "Regional Format", "Deutsch" is Selected. I'd like to change that with French(switzerland), but no way, it's not in the list.

Did anyone find a solution ? Is that a bug ?

Thanks a lot,

Hel

  • I have noticed that too. Actually I've never had a problem, but I must admit : it's a bit tricky to enable the Swiss French QWERTZ layout. During the installation of Ubuntu it's written something similar to "choose the language of your keyboard" and there are many languages listed such as German, Englisch, French. But under French nothing : the Swiss layout is missing. The trick is that in this list of languages, if you scroll down, there is an item called "Switzerland". I don't know why it's in the language list, but it's there.... – Johannes Lemonde Mar 25 '18 at 14:24
  • ... and if you click on it, there are all the options : "French (Switzerland)" amongst others. But there's another bug. If you select it and try to type with it, it reacts if it were the German variant of the Swiss layout, I mean there are the chars öäü instead of éàè. The second trick is to double click on your layout, and it will only work from then on. Bonne chance. – Johannes Lemonde Mar 25 '18 at 14:28
4

I don't know how you did your trick, but I have French (Switzerland), both as Regional Format and as Keyboard Layout.

Do you have French translations installed ? Because French(Switzerland) is part of "French" packages.

menu menu2

  • Ok. I installed French in Language Tab, and let English on the bottom of the list. I then went on "Regional Formats" Tab and, oh miracle, Français (suisse) is available in the drop list. unfortunatly, the date is still in German (donnerstag 25 September). :( – hel Sep 25 '14 at 19:08
  • I did logout/login -> and we are Jeudi ! Parfait merci ! – hel Sep 25 '14 at 19:26
3

Well, the language support stuff is organized per language, not by country. So you simply need to go to System Settings -> Language Support -> Install / Remove Languages and install French (even if you don't intend to use French as display language). Then you should be able to select fr_CH for regional formats.

As regards the keyboard layout, I'm pretty sure that French (Switzerland) was available at installation. Anyway, you can change it now, if you like, from System Settings -> Text Entry (se the answer provided by MrVaykadji).

  • I can assure you that I had to check "German (suisse)- Français (suisse)" (or something close) during the installation. I've juste found this bugrepport : bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1049609 – hel Sep 25 '14 at 19:12
  • @hel: Hmm.. That bug is claimed to be fixed in 13.04. Are you saying that it's still present? – Gunnar Hjalmarsson Sep 25 '14 at 20:06
  • I did install a 14.04, never touched Ubuntu before. BUT, it seems Debian related. I'll try again tomorrow. – hel Sep 25 '14 at 20:19
0

Intall language-pack-fr in a terminal, then edit your region & language settings ! You can then choose the Swiss format and new language!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.