2

I've spent several hours on making my videocard work after upgrading Ubuntu to 12.04. Nothing worked.

The latest attempts were:

  1. Installing the 'official' driver (http://us.download.nvidia.com/XFree86/Linux-x86/340.32/NVIDIA-Linux-x86-340.32.run), but then the installation procedure complained about installed nouveau driver. I have tried to remove/uninstall this driver by:

    • putting nouveau on the modprobe blacklist (see: How do I disable the "Nouveau Kernel Driver"?) and
    • by deleting the package: apt-get --purge remove xserver-xorg-video-nouveau. It didn't help; the installation procedure still detected a nouveau driver
  2. I added the xorg-edges PPA:

    sudo add-apt-repository ppa:xorg-edgers/ppa
    

then I installed the nvidia-graphics-drivers-340 (see http://www.ubuntuupdates.org/ppa/xorg-edgers) by this:

    $ sudo apt-get install nvidia-graphics-driver-340
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package nvidia-graphics-driver-340

How can I fix this?

7
  • The GT210 is well supported by the default nvidia-current proprietary driver as it is offered from your system settings. What made you believe you need newer drivers? Please remove the xorg-edgers ppa before you continue to install/upgrade anything. – Takkat Sep 24 '14 at 7:48
  • Immediately when starting up the first time as 12.04 xbmc program couldn't start and gave an error message about missing OpenGL driver. Then I decided to install/upgrade the drivers. Okay, I will remove the xorg-edgers ppa, but what then? – WillemJ Sep 24 '14 at 19:59
  • You should get an answer here: askubuntu.com/questions/301648/… - in case you had not messed up your installation too much simply installing nvidia-current should work (at least it did on my systems with a GT210, on 12.04 , and running xbmc Frodo). – Takkat Sep 24 '14 at 20:27
  • I followed up the directions, but failed when installing nvidia-current-updates sudo apt-get install nvidia-current-updates Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package nvidia-current-updates – WillemJ Sep 24 '14 at 20:50
  • Did you run apt-get update between the addition of the PPA and apt-get install? – David Foerster Mar 21 '15 at 10:48
6

I was having the same problem, and I fixed it by running the following commands in the terminal:

sudo apt-get purge nvidia* ## remove the previously installed proprietary driver
sudo reboot
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-340

That worked for me. Let me know how it goes for you.

2
  • I second this, it solved the wacky video driver issues I was having with (of all things) sub-menus and meta tags. – Ernie Aug 24 '15 at 21:52
  • tanks , it worked for me – Masoud Darzi Nov 24 '19 at 10:02
-1

12.04 is not the latest version. 15.04 is the latest version and instead of dist-upgrade I suggest a clean install. Backup all your data and clean install 15.04 and your drivers should be working just fine out of the box. If you find any problem then install again nvidia official drivers but it will work with the updated nouveu drivers included in 15.04.

5
  • This is not really a constructive answer - why do they have to upgrade? There's no reason to have them upgrade, really. – Thomas Ward Jun 15 '15 at 22:38
  • Because it has the latest drivers and an updated kernel – Brask Jun 15 '15 at 22:38
  • which if they have a system old enough will actually do more harm than good - my guess is they are using an old system that has an old card, therefore upgrading may actually harm the situation rather than make it better. I suggest you realize that the impact of nuking an installation and installing the latest can cause headaches if they need older hardware that is no longer supported by the proprietary drivers in later releases. – Thomas Ward Jun 15 '15 at 22:41
  • That is why kernels include older hardware support. – Brask Jun 15 '15 at 22:45
  • not all of them, and in 15.04 yuo see older hardware being phased out OF the kernels. This is why it's a bad recommendation - I have an 8 year old computer running Lubuntu that can't be upgraded past 14.04 because the graphics drivers (fglrx) don't support the hardware anymore. 14.04 it does. 15.04 it doesn't. – Thomas Ward Jun 15 '15 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.