2

I can't seem to keep my VPN connection alive. I'm using Ubuntu 14.04 64bit on a Toshiba Protege R30-A-17E.

The VPN connection just dies out after a random period of time no matter if I'm using it or not. I've tried a few things that I've found out either here or on some forums but it just keeps falling. I've tried disabling any kind of compression, activated the "send ppp echo packets" option. I've even tried to use a USB apple network ethernet adapter and still no luck.

Here is the contents of my syslog (grep'ed by -E "Network|pptp|pppd").

    Sep 23 10:56:35 IVO NetworkManager[765]: <info> Starting VPN service 'pptp'...
    Sep 23 10:56:35 IVO NetworkManager[765]: <info> VPN service 'pptp' started (org.freedesktop.NetworkManager.pptp), PID 20965
    Sep 23 10:56:35 IVO NetworkManager[765]: <info> VPN service 'pptp' appeared; activating connections
    Sep 23 10:56:35 IVO NetworkManager[765]: <info> VPN plugin state changed: starting (3)
    Sep 23 10:56:35 IVO NetworkManager[765]: <info> VPN connection 'WiseMetering' (Connect) reply received.
    Sep 23 10:56:35 IVO pppd[20969]: Plugin /usr/lib/pppd/2.4.5/nm-pptp-pppd-plugin.so loaded.
    Sep 23 10:56:35 IVO pppd[20969]: pppd 2.4.5 started by root, uid 0
    Sep 23 10:56:35 IVO pppd[20969]: Using interface ppp0
    Sep 23 10:56:35 IVO pppd[20969]: Connect: ppp0 <--> /dev/pts/54
    Sep 23 10:56:35 IVO NetworkManager[765]:    SCPlugin-Ifupdown: devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
    Sep 23 10:56:35 IVO NetworkManager[765]:    SCPlugin-Ifupdown: device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
    Sep 23 10:56:35 IVO NetworkManager[765]: <warn> /sys/devices/virtual/net/ppp0: couldn't determine device driver; ignoring...
    Sep 23 10:56:35 IVO pptp[20972]: nm-pptp-service-20965 log[main:pptp.c:314]: The synchronous pptp option is NOT activated
    Sep 23 10:56:35 IVO pptp[20984]: nm-pptp-service-20965 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 1 'Start-Control-Connection-Request'
    Sep 23 10:56:35 IVO pptp[20984]: nm-pptp-service-20965 log[ctrlp_disp:pptp_ctrl.c:739]: Received Start Control Connection Reply
    Sep 23 10:56:35 IVO pptp[20984]: nm-pptp-service-20965 log[ctrlp_disp:pptp_ctrl.c:773]: Client connection established.
    Sep 23 10:56:36 IVO pptp[20984]: nm-pptp-service-20965 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 7 'Outgoing-Call-Request'
    Sep 23 10:56:36 IVO pptp[20984]: nm-pptp-service-20965 log[ctrlp_disp:pptp_ctrl.c:858]: Received Outgoing Call Reply.
    Sep 23 10:56:36 IVO pptp[20984]: nm-pptp-service-20965 log[ctrlp_disp:pptp_ctrl.c:897]: Outgoing call established (call ID 0, peer's call ID 11648).
    Sep 23 10:56:39 IVO pppd[20969]: CHAP authentication succeeded
    Sep 23 10:56:39 IVO pppd[20969]: MPPE 128-bit stateless compression enabled
    Sep 23 10:56:41 IVO NetworkManager[765]: <info> (eth0): IP6 addrconf timed out or failed.
    Sep 23 10:56:41 IVO NetworkManager[765]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
    Sep 23 10:56:41 IVO NetworkManager[765]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) started...
    Sep 23 10:56:41 IVO NetworkManager[765]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
    Sep 23 10:56:41 IVO pppd[20969]: local  IP address 192.168.200.67
    Sep 23 10:56:41 IVO pppd[20969]: remote IP address 192.168.200.1
    Sep 23 10:56:41 IVO pppd[20969]: primary   DNS address 192.168.200.1
    Sep 23 10:56:41 IVO pppd[20969]: secondary DNS address 192.168.200.1
    Sep 23 10:56:41 IVO NetworkManager[765]: <info> VPN connection 'WiseMetering' (IP4 Config Get) reply received from old-style plugin.
    Sep 23 10:56:41 IVO NetworkManager[765]: <info> VPN Gateway: 194.38.128.63
    Sep 23 10:56:41 IVO NetworkManager[765]: <info> Tunnel Device: ppp0
    Sep 23 10:56:41 IVO NetworkManager[765]: <info> IPv4 configuration:
    Sep 23 10:56:41 IVO NetworkManager[765]: <info>   Internal Address: 192.168.200.67
    Sep 23 10:56:41 IVO NetworkManager[765]: <info>   Internal Prefix: 32
    Sep 23 10:56:41 IVO NetworkManager[765]: <info>   Internal Point-to-Point Address: 192.168.200.1
    Sep 23 10:56:41 IVO NetworkManager[765]: <info>   Maximum Segment Size (MSS): 0
    Sep 23 10:56:41 IVO NetworkManager[765]: <info>   Static Route: 192.168.200.0/24   Next Hop: 192.168.200.0
    Sep 23 10:56:41 IVO NetworkManager[765]: <info>   Static Route: 192.168.1.0/24   Next Hop: 192.168.1.0
    Sep 23 10:56:41 IVO NetworkManager[765]: <info>   Forbid Default Route: yes
    Sep 23 10:56:41 IVO NetworkManager[765]: <info>   Internal DNS: 192.168.200.1
    Sep 23 10:56:41 IVO NetworkManager[765]: <info>   DNS Domain: '(none)'
    Sep 23 10:56:41 IVO NetworkManager[765]: <info> No IPv6 configuration
    Sep 23 10:56:42 IVO NetworkManager[765]: <info> VPN connection 'WiseMetering' (IP Config Get) complete.
    Sep 23 10:56:42 IVO NetworkManager[765]: <info> Policy set 'Wired connection 1' (eth0) as default for IPv4 routing and DNS.
    Sep 23 10:56:42 IVO NetworkManager[765]: <info> Writing DNS information to /sbin/resolvconf
    Sep 23 10:56:42 IVO NetworkManager[765]: <info> VPN plugin state changed: started (4)
    Sep 23 10:57:36 IVO pptp[20984]: nm-pptp-service-20965 log[logecho:pptp_ctrl.c:677]: Echo Reply received.
    Sep 23 11:06:37 IVO pptp[20984]: message repeated 9 times: [ nm-pptp-service-20965 log[logecho:pptp_ctrl.c:677]: Echo Reply received.]
    Sep 23 11:06:37 IVO pptp[20984]: nm-pptp-service-20965 log[logecho:pptp_ctrl.c:679]: no more Echo Reply/Request packets will be reported.
    Sep 23 11:17:37 IVO pptp[20984]: nm-pptp-service-20965 log[pptp_handle_timer:pptp_ctrl.c:1050]: closing control connection due to missing echo reply
    Sep 23 11:17:37 IVO pptp[20984]: nm-pptp-service-20965 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request'
    Sep 23 11:17:37 IVO pptp[20984]: nm-pptp-service-20965 log[pptp_conn_close:pptp_ctrl.c:430]: Closing PPTP connection
    Sep 23 11:17:37 IVO pptp[20984]: nm-pptp-service-20965 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 3 'Stop-Control-Connection-Request'
    Sep 23 11:17:37 IVO pptp[20984]: nm-pptp-service-20965 log[call_callback:pptp_callmgr.c:79]: Closing connection (call state)
    Sep 23 11:17:37 IVO pppd[20969]: Modem hangup
    Sep 23 11:17:37 IVO pppd[20969]: Connect time 21.0 minutes.
    Sep 23 11:17:37 IVO pppd[20969]: Sent 10793 bytes, received 9913 bytes.
    Sep 23 11:17:37 IVO pppd[20969]: MPPE disabled
    Sep 23 11:17:37 IVO pppd[20969]: Connection terminated.
    Sep 23 11:17:37 IVO NetworkManager[765]: <info> VPN plugin state changed: stopping (5)
    Sep 23 11:17:37 IVO NetworkManager[765]: <info> VPN plugin state changed: stopped (6)
    Sep 23 11:17:37 IVO NetworkManager[765]: <info> VPN plugin state change reason: 0
    Sep 23 11:17:37 IVO pppd[20969]: Exit.
    Sep 23 11:17:38 IVO NetworkManager[765]: <info> Policy set 'Wired connection 1' (eth0) as default for IPv4 routing and DNS.
    Sep 23 11:17:38 IVO NetworkManager[765]: <info> Writing DNS information to /sbin/resolvconf
    Sep 23 11:17:38 IVO NetworkManager[765]: <warn> error disconnecting VPN: Could not process the request because no VPN connection was active.
    Sep 23 11:17:38 IVO NetworkManager[765]: <warn> (45) failed to find interface name for index
    Sep 23 11:17:38 IVO NetworkManager[765]: nm_system_iface_flush_routes: assertion 'iface != NULL' failed
    Sep 23 11:17:38 IVO NetworkManager[765]: <warn> (45) failed to find interface name for index
    Sep 23 11:17:38 IVO NetworkManager[765]:    SCPlugin-Ifupdown: devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
    Sep 23 11:17:43 IVO NetworkManager[765]: <info> VPN service 'pptp' disappeared

Does anyone have a clue to what's happening here?

EDIT

I have 2 different laptops, both running Ubuntu 14.04 64bits (actually one of them is running Xubuntu, but that's basically the same).

Both these laptops show the exact same behavior with the VPN randomly disconnecting after logging something like "closing control connection due to missing echo reply" to syslog.

I also have a small netbook on which I've installed #!11 (which still runs kernel 3.2 btw). With the exact same config the VPN here has not disconnected for a little over 10 hours and the only reason it disconnected from the VPN is because I told it to.

So.. could this be a Ubuntu 14.04 problem? or a Kernel problem? or a lib version problem?

1

1 Answer 1

1

Chances are the VPN server doesn't support some compression features. If the server is windows based, try to disable PPP Echo packets sending, also disabling BSD compression, Deflate compression and TCP header compression might solve the problem. If the issue persists, DNS error might be the culprit.

1
  • Hi! thank you for answering. I did what you said and still no luck. I'm using Ubuntu 14.04 64bit on 2 different laptops and both exhibit the same behavior. I also have a small netbook on which I have #!11 installed. On this computer, with the exact same configs the VPN is very stable and didn't fell a single time for 10 hours straight.. so, I'm thinking this is some sort of Ubuntu 14.04 related problem (or kernel problem, IDK.....)
    – Lynx_Eyes
    Sep 25, 2014 at 21:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .