33

Sorry if this question is already answered, but I have already searched and could not find a solution to my problem.

Recently I installed gnome-shell and ubuntu-gnome-desktop to try gnome. I then removed it using

sudo apt-get remove gnome-shell ubuntu-gnome-desktop.

From that moment I couldn't change my desktop wallpaper. Also, when I right click on my desktop it doesn't work.

I read in some links to check if xfdesktop is running... In my ubuntu, that process is not running. When I run xfdesktop from terminal, it gives me the following error:

SESSION_MANAGER environment variable is not defined. Failed to connect to session manager.

I don't know if it has any relation to my problem.

Another thing I observed is that gnome-system-monitor and gnome-session are still running on my ubuntu... why are they running if I want Unity only?

Is there any way to reset my ubuntu to as it was initially. But I have also installed some useful applications and packages in this, can I keep them even after resetting?

Thank you in advance!

  • I think this is a duplicate of or at least very similar to 287571 Gnome-shell disables Nautilus handling the desktop and so on Unity no wallpaper and no destop-icons are available anymore. – Christian Sep 23 '14 at 8:14
  • Thank you @Christian, this started changing the wallpaper. But Still right click and super key is not working when I am at Desktop. – user3903448 Sep 23 '14 at 11:24
  • Is Gnome-Tweak-Tool still installed? There is an option to let Nautilus handle the desktop. This must be set. According to the second answer to the mentioned question, this can also be done with "ubuntu-tweak-tool" which I do not know. – Christian Sep 23 '14 at 12:28
  • I think this might help you: askubuntu.com/questions/140944/… – Saman B. Feb 3 '15 at 18:54
  • The gnome tweak tool did it for me, the option was already set, I just toggled it and it started working again. I not have backgrounds and can right click – Keith Jun 7 '15 at 7:16
80

I had the exact same problem.
Tried everything in the book!
This is what worked for me.
Hope your problem is solved soon.

gsettings set org.gnome.settings-daemon.plugins.background active true
  • This worked for me. Thanks – skay- Jun 21 '15 at 13:48
  • 3
    Worked !! But what was the reason? I didn't get it. – Chaitanya Chandurkar Jul 2 '15 at 0:28
  • @Karan: I agree--what's the rationale here? – jvriesem Feb 27 '16 at 20:57
  • 1
    This solution gave me back my changing wallpapers, but didn't allow me to click. This fixed the clicking problem for anyone that needs it: askubuntu.com/questions/142247/… – Kimberly W May 7 '16 at 14:27
  • 1
    Worked for me on Ubuntu 16.04.2. It's bizarre how something basic like this could be broken out of the box... – Pupper Jun 6 '17 at 2:05
5

After installing or removing of ubuntu-gnome-desktop a bug of Desktop not responding to clicks/icons can occur, You may reactivate:

Active Desktop Background:

gsettings set org.gnome.settings-daemon.plugins.background active true

Active Desktop Icons:

gsettings set org.gnome.desktop.background show-desktop-icons true
1

Use the gnome-tweak-tool. Click the Desktop button (left side) Set:

Mode = Scaled
Background Location = ...image path
0

This happened to me too after I installed Gnome-Shell. Uninstalling it and rebooting restored the desktop clickability and brought back the desktop icons too.

protected by Community Sep 21 '18 at 14:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.