1

I have install Ubuntu 14.04 on my system. The problem I am facing is with default font rendering. Since I cannot yet upload image, I have added links to imgur here to explain the problem.

Font rendering in Ubuntu, Consolas 12

Font rendering in Fedora with infinality, Consolas 12

Font rendering in Fedora is very crisp and size also changes smoothly, fonts in Ubuntu on the other hand, becomes either too large or too small. Many other fonts also render much better on Fedora with infinality.

Is there a way to achieve that in Ubuntu? I have already tried Infinality from no1wantedthisname using

sudo add-apt-repository ppa:no1wantdthisname/ppa
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fontconfig-infinality

I suspect default rendering in Ubuntu comes in conflict with Infinality. Any help will be great.

Thanks in Advance

  • Have you tryed Google better font in ubuntu site it explains better font. – Michael Oct 2 '14 at 13:15
5

Update

Old answer is incorrect and it fails after system upgrade. No need to install infinality-ultimate. Do the following instead:

$ sudo add-apt-repository ppa:no1wantdthisname/ppa
$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install fontconfig-infinality

$ sudo bash /etc/fonts/infinality/infctl.sh setstyle
# set to win7

$ sudo gedit /etc/profile.d/infinality-settings.sh
# set USE_STYLE to WINDOWS7

These are the instructions already given on github.com/achaphiv/ppa-fonts/blob/master/ppa/README.md which I missed.

--Old Answer--

Since posting the question I found a solution myself, though I am not clear why it worked. Here it is:

  1. Used a fresh install without Infinality install
  2. Add PPAs

    $ sudo add-apt-repository ppa:no1wantdthisname/ppa
    $ sudo add-apt-repository ppa:rjvbertin/infinaltimate
    $ sudo apt-get update
    
  3. $ sudo apt-get install fontconfig-infinality

  4. Use

    $ sudo bash /etc/fonts/infinality/infctl.sh setstyle
    

    and set style to Windows 7. Logout and Log back in.

  5. Now install bohoomil's infinality-ultimate patches. I installed almost all packages to be sure

    $ sudo apt-get install fontconfig
    $ sudo apt-get install fontconfig-config
    $ sudo apt-get install fontconfig-infinality-fonttweaks
    $ sudo apt-get install libfontconfig1
    $ sudo apt-get install libfontconfig1-dev
    
    $ sudo apt-get install libfreetype6
    $ sudo apt-get install libfreetype6-dev
    
  6. Logout and log back in. Install unit-tweak-tool for easy font settings. This is the final result.

  7. Antialiasing: RGBA, Hinting: Full and Font: Consolas 12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.