2

I'm trying to install sip for pyqt and trying to get checkinstall to work. But it keeps saying

    Installing Debian package... FAILED!

This is what's in the log file:

    (Reading database ... 191312 files and directories currently installed.)
    Preparing to unpack .../sip_4.16.3-1_amd64.deb ...
    Unpacking sip (4.16.3-1) ...
    dpkg: error processing archive /home/user/sip-4.16.3/sip_4.16.3-1_amd64.deb (--install):
    trying to overwrite '/usr/include/python2.7/sip.h', which is also in package python-sip-dev 4.15.5-1build1
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Errors were encountered while processing: /home/user/sip-4.16.3/sip_4.16.3-1_amd64.deb

Anyone know how I can fix this and get it to work? I can't find anything on what to do to fix this.. It looks like sip was installed successfully - as I can check the version number.

There also seems to be a deb file in the sip-4.16.3 folder. But when I try to install or remove, I get

    dpkg: error processing archive sip_4.16.3-1_amd64.deb (--install):
    trying to overwrite '/usr/include/python2.7/sip.h', which is also in package python-sip-dev 4.15.5-1build1
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Errors were encountered while processing: sip_4.16.3-1_amd64.deb

1 Answer 1

0

You already have SIP installed.

Your error message says that the file /usr/include/python2.7/sip.h already exists, and is part of the python-sip-dev file.

You can fix this in two ways:

  1. Uninstall python-sip-dev using sudo apt-get uninstall.
  2. Do nothing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.