2

I have Ubuntu 14.04 LTS installed in a dual boot along with Windows 8.

When I create a desktop shortcut for a folder on a windows partition in Ubuntu using "Make a link and move it to the desktop", it won't work after I reboot.

It tells me "the link is broken, move it to trash?".

I searched for similar problems but the proposed solutions didn't work.

marked as duplicate by Jacob Vlijm, Eric Carvalho, αғsнιη, Kaz Wolfe, Thomas Ward Oct 25 '14 at 4:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Welcome to Askubuntu! What program are you making a link to? – Aaron Hill Sep 22 '14 at 23:02
  • Is it a link to a Windows partition? – Jacob Vlijm Sep 23 '14 at 6:39
  • It's not a program , it's a folder on a windows partition – MChawa Sep 23 '14 at 11:00
  • /etc/fstab. Ask me more if you need directions. – Paul Stelian Sep 23 '14 at 11:38
  • Guys I tried to auto mount the disk or manually mount it, But still I can't use the shortcut after a reboot ... any solutions ? – MChawa Sep 23 '14 at 17:10
1

Since windows partitions are in NTFS file system type and they are not already auto-mount after login and when you mount them for this time and make form them a link, but after next reboot they are not mounted and Ubuntu not detect them at startup, so you will see error when you want to use that links:

"the link is broken, move it to trash?"

solutions:

  1. Mount those partition after each login manually and then use created link form them.
  2. Make them as auto-mount after next login and after system starts by following these links:

How to mount a new drive on startup

Is there a program to mount all of my drives automatically?

3. tested solution: Type "Disks" in dash and hit enter to open that.

enter image description here

  • Select your partition that you created a link from it(point 1)
  • Click on "More Actions" (gear icon point 2)
  • Select "Edit Mount Options..." (point 3)

this window will open:

                    enter image description here

  • Drag "On/Off" slider to left side to make it "Off" (point 4)
  • Checked "Mount at startup" check box (point 5)
  • Now click "Close" and also close "Disks" utility.

Test step: Reboot your system and check, you will not see any more that error.

Cool!

  • The problem remains even after I mount the drive and still I can't use the shortcut , I don't know how to prove this ?! any solutions ? – MChawa Sep 23 '14 at 17:09
  • @user2136465 wait for check that for my self... – αғsнιη Sep 23 '14 at 17:11
  • +1 @user2136465 Ok you are right, after next reboot not working, wait for finding solution... – αғsнιη Sep 23 '14 at 17:54
  • @user2136465 Problem solved. check updated answer. – αғsнιη Sep 23 '14 at 18:44
  • 1
    Thanks Buddy It worked , But I just wanna tell ubuntu developers this should be something already existing in the os !!! – MChawa Sep 24 '14 at 7:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.