Following the instructions here (https://wiki.ubuntu.com/KernelTeam/GitKernelBuild) I built a development version of the kernel.

I copied the old config, called make oldconfig and then modified .config in the source tree in order to set a configuration flag:


Then I built it with make -j `getconf _NPROCESSORS_ONLN` deb-pkg LOCALVERSION=-custom and installed the resulting packages with dpkg -i, yet the new flag has no effect:

$ uname -r
$ grep CONFIG_ACPI_DEBUG /boot/config-$(uname -r)
# CONFIG_ACPI_DEBUG is not set

How can I compile a kernel with different flags in Ubuntu?

  • When you edited .config, did you read the text at the top? It says Automatically generated file; DO NOT EDIT. After using make oldconfig, try to use make menuconfig and use that to enable ACPI debug. It'll take care of the dependencies the various config options have.
    – Jan
    Sep 22, 2014 at 20:05
  • I checked menuconfig. In the ACPI menu, the option Debug statements, whose additional information tells it is CONFIG_ACPI_DEBUG, is checked.
    – Alicia
    Sep 22, 2014 at 20:09
  • Is it wrong to edit the kernel parameters as a text file?
    – Alicia
    Sep 22, 2014 at 20:10
  • It's not wrong per se, but some config options depend on others, the target menuconfig takes care of that.
    – Jan
    Sep 22, 2014 at 20:32
  • 1
    In the end, it was a silly thing. I was choosing the wrong kernel in GRUB.
    – Alicia
    Sep 23, 2014 at 21:07


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.