I run Ubuntu 14.04 64 bit and I have a Canon PIXMA MG5450 printer connected to the PC with cable. I turn it on and it is not recognized automatically, I can't find any drivers official drivers for it.

Is there any unofficial driver that make it work?


1 Answer 1


On the Swiss Canon support site, I found the driver source code for the PIXMA MG5400. Just scroll all the way down and hit "Akzeptieren & Herunderladen" (Accept and Download).

You'll receive a tar.gz archive containing the source code. Extract it and open a terminal in the directory cnijfilter-source-3.80-1 where you extracted it.

Execute the command chmod +x scripts/install_deb/install.sh, then execute scripts/install_deb/install.sh

The make, make install way doesn't work, as the Makefile is corrupted...

This might do it. However, I don't know how old this is and how well it is maintained.

EDIT: The other answer points to Canon Singapore, which provides a prepackaged version of the driver for Debian: http://support-sg.canon-asia.com/contents/SG/EN/0100467602.html?r=s&q=

Download, extract, and run the installer script.

  • When I run install.sh I get: An error occurred. A necessary package could not be found in the proper location. I think the script is last modified in 2012. Because I see Copyright CANON INC. 2001-2012
    – aegyed
    Sep 22, 2014 at 20:05
  • Then try cd scripts/install_deb && ./install.sh
    – s3lph
    Sep 22, 2014 at 20:06
  • Actually I executed the script from the install_deb directory.
    – aegyed
    Sep 22, 2014 at 20:07
  • Then don't do it, but from the directory with the Makefile in it.
    – s3lph
    Sep 22, 2014 at 20:08
  • The Makefile is in the root folder cnijfilter-source-3.80-1 I get the same error if i try to execute the isntall.sh from there as well. scripts/install_deb && ./install.sh or scripts/install_deb/install.sh
    – aegyed
    Sep 22, 2014 at 20:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.