2

Have added several custom wallpapers as previously done in the past, by adding them into the /usr/share/backgrounds/ directory, then adding a custom XML file copied from the numix style wallpapers and calling it mypics.xml which is added under /usr/share/gnome-background-properties/ directory.

Permissions and ownership are all correct as matches the working backgrounds, but for some reason, the backgrounds no longer show in the Appearance options. They do on another computer using the exact same method without issue.

The only difference here is that the entire hard-drive is encrypted (not sure that makes any difference whatsoever) whereas only the home directory is encrypted on the other machine. In one scenario, no issues, but in the other - it fails to alter the Appearance tab even after reboot.

Am I missing some crucial bit of information here? Is there another piece to the equation missing somewhere?

  • 1
    Your wording is confusing. Can you please restructure the question to clearly specify which configuration is failing:- 1. The partly encrypted one 2. The fully encrypted one – ksinkar Oct 14 '14 at 8:55
  • 1
    2. The fully encrypted one (is failing). :: I'm not the owner, but on his statements, to me, it looks clear which is which. – The Eye Oct 14 '14 at 11:27
  • It would seem to me that home folder encryption would more likely fail if appearance tab polling happens on logout/login, so I understand the concern for clarification from @ksinkar . Whole disk should act exactly like unencrypted, since there's no waiting for a folder to unlock during the sign-on process. – RobotHumans Oct 19 '14 at 11:55
  • Sorry all, started new job, forgot to check in. The hard drive with full encryption is the one where I ran into the issues, not a real big one to bother on, but was just awkward. Will be rebuilding that image on Trusty again soon, to reflect my new priorities in support. – freecode Oct 20 '14 at 20:17
2

Well, first you need to make a backup file with the /usr/share/gnome-background-properties/trusty-wallpapers.xml made, it will open this file with gedit with root permissions, and will do the following modifications.

<? xml version = "1.0" encoding = "UTF-8"?>
<! DOCTYPE wallpapers SYSTEM "gnome-wp-list.dtd">
<Wallpapers>
  <wallpaper>
    <name> My 1st Wallpapers </ name>
    <filename> .local / share / backgrounds / wallpaper1 / My1stSlideshow.xml </ filename>
    <options> zoom </ options>
    <pcolor> # 000000 </ pcolor>
    <scolor> # 000000 </ scolor>
    <shade_type> Solid </ shade_type>
  </ wallpaper>
</ wallpapers>

This is an example of Gnome, the necessary changes will be the name of the desired wallpaper, its logical address (filename), in the only repeat this pattern. For example insert a photo name "Eclipse" which is in /usr/share/background/Eclipse.jpg will be as follows:

<wallpaper>
    <name> Eclipse </ name>
    <filename>/usr/share/background/Eclipse.jpg </ filename>
    <options>zoom</ options>
    <pcolor>#000000</ pcolor>
    <scolor> # 000000 </ scolor>
    <shade_type> Solid </ shade_type>
  </ wallpaper>

What is above and below should remain as it is (including spaces (indentation)). Obs .: If when you open the "appearence" appears duplicate wallpapers, do not worry, see if there is duplicate scripts, using "ls -a / usr / share / gnome-background-properties /" appear some script as trusty-wallpapers .xml ~ delete it, and restart the appearence, then you can enjoy your wallpaper, attention also in the resolution of your wallpaper

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.