1

I have Ubuntu 14.04 on a VMWare on my computer. I've been using it for a few months now for research for school. However, suddenly, I can't log in. When I get to the login screen, I enter my password, the user name and password display disappears, and it just sits at the splash screen indefinitely.

I've tried several methods mentioned on the internet, such as renaming the .Xauthority file, but when this happens, I GET the infinite loop error that everyone says that's supposed to fix. When I log in, it creates a new .Xauthority file for me, but it's 0 kb in size. Then, when I log in, it just loops back to the log in screen. If I revert to the old file, I get the original error.

My other issue is that I've seen it mentioned to just reinstall the desktop. The problem I'm running into there is my harddrive is FULL and I have a program that I used apt-get install for. It didn't finish downloading and has about 350mb left to go. When ever I try to uninstall anything, or reinstall the desktop, I'm told to run: apt-get -f install to take care of some dependencies.

If I do, I'm told I'm out of disk space.

I've also tried adding another hard disk, but can't do anything with it under Guest (I can't access them and unload files onto them to create some space).

I feel like I'm really up a wall here and am unsure of what more to do. Any ideas or recommendations?

Thanks for the help.

  • What packages does apt-get say are missing when you're told to use apt-get install -f? – Aaron Hill Sep 22 '14 at 22:38
  • I was installing LaTex. – Justin Lloyd Sep 23 '14 at 0:47
1

Okay, fixed the issue.

I had to go in using ctrl + alt + f2 and logged into my account. I then deleted my dropbox folder (to free enough space, which was around 800mb).

At that point, I did a sudo apt-get -f install which allowed me to finish downloaded LaTex. Once it was fully downloaded, it told me there were dependency issues, so I uninstalled it using sudo apt-get remove tex-common and then a sudo apt-get autoremove to finish it off. Once that was finally out of the way, I could then run sudo apt-get install ubuntu-desktop, and then sudo apt-get update.

Went back to the login screen, put in my password, and I was back in.

Frustrating, but taken care of. Thanks.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.