Earlier mobile broadband connection seems to work flawlessly but after Upgrading trusty tahr 14.04.1 to linux image 3.13.0-35 there seems to be problem.

First it started popping for USB modem password.

when tried to start it all over again by deleting the connection. network manager doesn't show the mobile broadband option.

lsusb shows the device.

Let me know which module is missing and need to be downloaded.

  • what is your 3g/4g stick brand ? – Amir Sep 22 '14 at 17:22
  • reinstall NetworkManager using apt. – LittleByBlue Sep 22 '14 at 17:23
  • You will have to use an older kernel and file a bug report. Re-installing NetworkManager is unlikely to resolve your problem. – Panther Sep 22 '14 at 17:29
  • execute this command in the terminal: sudo service mobile-broadband-connect start or first do the stop (sudo service mobile-broadband-connect stop ) and then start. Then get the status by: sudo service mobile-broadband-connect status – Amir Sep 22 '14 at 17:32
  • @bodhi.zazen- tried to switch older kernel didn't solved the problem but got a work around got new installation of 14.04.1 beside older one so once USB get detected in that version switch(restart) over to new version. May it help someone. In meantime will try to solve the problem. – webd Sep 29 '14 at 5:33

this thread solved the problem of not detecting modem by Network Manager.

Huawei E3272 Ubuntu

Its adding rule for your Vendor and Productid if it gets detected in lsusb.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.