2

I have one monitor that I use for both my PC (via VGA) and my Linux machine (via DVI). I just use it for one computer at a time, by pulling out the not needed cable and plugging in the required one.

But when I unplug the DVI, after starting Linux, and then plug it back in, I just get a black screen and I have to reboot the Linux machine to get anything to happen.

How can I get it to work properly? ( I don't get this issue reconnecting to my Windows PC)

  • it's always interesting which version of ubuntu you are using – Private Sep 22 '14 at 11:20
  • Im using latest version of Xbuntu – Paul Taylor Sep 22 '14 at 11:38
  • What Graphics Card are you using, and with which driver? – s3lph Sep 22 '14 at 12:21
  • Have you tried connecting the Linux box via VGA? Different results? – Elder Geek Dec 11 '14 at 14:47
0

Go to

  • system settings
  • Brightness & Lock

Switch "Turn screen off when inactive for" to "Never"

Never switch off

For Xubuntu :

Go to "Power Manager"
Tab "On AC"
Tab "Monitor".
Set "Switch off display when computer is inactive" to never
  • I'm using latest version of Xubuntu - I couldn't find that option but I did find the similar Light Locker and also Power Manager. I changed all settings to Never, unplugged DVI cable expecting that it was solved but no change, back to blank screen :( – Paul Taylor Sep 22 '14 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.