I am trying to install Guest Additions in VirtualBox with Windows XP host and Ubuntu 12.04 guest. I followed the above steps:

Devices-> Insert Guest Additions CD Image.
After that I locate the folder /media/VBoxAdditions4.3.4_91027/
and run sudo ./VBoxLinuxAdditions.run

I want to be able to create shared folders and adjust the resolution of the screen. I achieved to do the first issue, but I couldn't do the second one. I didn't get any message, however it is not possible to change the resolution of the screen and I cannot switch to fullscreen. What am I doing wrong?

I found in the instal log the following message: unknown version of the X Window System. I've tried the solution of the proposed link but I got the following message:

Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
virtualbox-guest-x11 : Depends: xorg-video-abi-11
                    Depends: xserver-xorg-core (>= 2:
E: Unable to correct problems, you have held broken packages.

I tried also to install with the command sudo apt-get install virtualbox-guest-dkms but nothing is changing. During the installation of dkms I got the message: Error! Bad return status for module build on kernel 3.13.0-32-generic(i686).

  • I ve already track this, tried it, but didnt work! – Jose Ramon Sep 22 '14 at 8:12
  • 1
    It is a dupe. The package error is another issue that you may fix here. – Lucio Sep 23 '14 at 2:21
  • 2
    @Lucio - This is not even close to a dup. This question is about a specific situation that happens on a fresh Umbutu install. That question is about cleaning up a package database that has become messed up. This question is about dealing with a base install with a display that is too small to be usable, that question's answers suggest using the GUI. It answers are simply not usable to answer this question. – T.E.D. Dec 30 '15 at 17:26
  • I am really surprised that this question got closed as duplicate of those ones. – brandizzi Feb 21 '18 at 10:32


It seems that conradk solution is working so I'll post it here in the answer as well.

  • I did sudo apt-get remove libcheese-gtk23, then sudo apt-get install xserver-xorg-core and finally sudo apt-get install -f virtualbox-guest-x11. It solved problems for me

Scroll down and give him a vote up if this works for you.

I looked up your problem on google and this is what I found.

Just running the below will take care of installing the package and all its dependencies. However, it seems to be taking some time for it to complete, so be ready for a long wait.


$ sudo apt-get -q -y -f build-dep virtualbox-ose-guest-utils virtualbox-guest-x11 virtualbox-ose-guest-x11 virtualbox-ose-guest-dkms

This will install all dependencies for 'packagename' so it can build it.

After the building has completed just install it again by typing:

$ sudo apt-get -q -y -f install virtualbox-ose-guest-utils virtualbox-guest-x11 virtualbox-ose-guest-x11 virtualbox-ose-guest-dkms

You can read about the options for apt-get with $ man apt-get.


  1. Ubuntu The following packages have unmet dependencies: $package1 : Depends: $package2 but it is not going to be installed
  • 3
    Does not work for 14.04.2: E: Unable to find a source package for virtualbox-ose-guest-utils – Rufus_12 Feb 24 '15 at 15:42
  • 40
    I did sudo apt-get remove libcheese-gtk23, then sudo apt-get install xserver-xorg-core and finally sudo apt-get install -f virtualbox-guest-x11. It solved problems for me. – conradkleinespel Apr 1 '15 at 20:03
  • 4
    @conradk you sir are a life saver! None of the blogs/posts/answers solved it, then looking at your little tiny comment did it for me. I want to buy you a beer! – wael34218 Apr 10 '15 at 21:53
  • 1
    After installing these three items, sudo apt-get remove libcheese-gtk23; sudo apt-get install xserver-xorg-core;sudo apt-get install -f virtualbox-guest-x11; I got resolution problem fixed, but my ubuntu desktop is blank and I can not do anything. – Haider Ali Wajihi Jun 25 '15 at 7:41
  • 1
    After installing as above, sometimes the desktop doesnt give option for system settings, then use sudo apt-get install ubuntu-desktop or use sudo apt-get install unity-control-center – ravi.zombie Dec 15 '15 at 2:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.