0

I recently did the automatic upgrade from 12.04 to 14.04, but I can't log in to my Ubuntu boot anymore.

I get a dark blue/black screen after the Ubuntu loading screen. If I move the mouse, I can see it, but no screen loads. I am able to ctrl-alt-f1 and get a login screen, and from there can do 'sudo service light-dm start'. This will get me a login screen, but when I go to log in, it will take me back to the login screen over and over.

I reinstalled fglrx several times, as well as ubuntu-desktop. The logs all look fine. I also regenerated xorg.conf.

The only thing I see wrong is that fglxrinfo returns Error: unable to open display (null) instead of what it's supposed to return.

Any idea what is causing this error, and how to fix my GUI?

Edit: I noticed that sometimes when go over to ctrl-alt-f1, it's hung up on either mysql or it just finished loading "networking." I'll check the network log next.

  • Did you actually upgrade all the way to 14.10, or do you mean 14.04? – Eliah Kagan Sep 22 '14 at 3:43
  • What tool or command did you use to do the upgrade? – thomasrutter Sep 22 '14 at 3:49
  • @eliahkagan yea, sorry. I'll fix it when I get to a computer. – JFA Sep 22 '14 at 14:25
  • @neon_overload a window popped up asking if I wanted to upgrade and I said yes. – JFA Sep 22 '14 at 14:26
  • @JFA this will help for sure : askubuntu.com/questions/223501/… – igaurav Sep 23 '14 at 5:34
0

i had a similar issue and the problem was the permission with the file ~/.Xauthority so i took backup and deleted it and rebooted this solved my login issue

  • That didn't seem to work, and I can't even launch the login screen now with start lightdm – JFA Sep 22 '14 at 14:24
  • This is the solutions i used for my issue askubuntu.com/questions/223501/… – Fat Mind Sep 23 '14 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.