13

Is there a way to set the screen borders manually? Right now when I have it connected to my TV via HDMI, the edges of the screen are cut off. It looks something like this that I found from another ask question

As you can see, the launcher is cut off

Card: AMD Radeon HD 4890 TV: Panasonic th-50px60u

  • 4
    change your TV settings, something "Fit screen" – αғsнιη Sep 21 '14 at 19:49
  • 2
    My TV doesn't have a setting like that unfortunately – Chaos Sep 21 '14 at 19:50
  • 3
    see askubuntu.com/questions/4358/… – αғsнιη Sep 21 '14 at 19:52
  • 2
    I have a older Panasonic TV, which like I JUST said, doesn't have a setting like that. – Chaos Sep 21 '14 at 19:53
  • 1
    Setting the resolution doesn't matter, still has edges cut off. – Chaos Sep 21 '14 at 20:04
23

What you are looking at is a"feature called "overscan" (or "zoom" on some TVs). It's the TV itself cutting off the edges!

So, look for a feature called overscan (or zoom) in the setup of the TV, and disable it!

Some history:

Long time ago, when cathode ray tubes - CRTs - were used as television displays, and the images were transferred in an analogue way, it had a technical reason, it was useful.
The TV stations were used to always have a border with nothing important in it.

With pixel matrix displays like LCD, overscan no longer makes sense.
But people are used to have it, and think it's better to have the feature than not have it.

If you want to sell LCD TVs, you have customers asking for it, and because it costs nothing to provide it, you better list that feature in the description.
It will not do any harm, no problem. Except if someone enables it.

  • 2
    Correct, to the point, complete and the answer to the question!! And still you get two downvotes without comment. This was exactly the solution for my TV! (One upvote from me! And an edit) – Fabby Jan 14 '15 at 23:46
  • 1
    Oh, thanks! I was starting to think I somehow missed the point and better delete the answer. Maybe it's just that I could not convince the OP that his TV has an overscan setting at all. – Volker Siegel Jan 15 '15 at 9:48
  • 1
    Ah, just noticed you found the overscan setting in the manual - but with a different name than "overscan" - oh, I explicitly wrote "called overscan" - will fix that. – Volker Siegel Jan 15 '15 at 9:52
  • Done already!!! :D :D :D – Fabby Jan 15 '15 at 9:53
  • It's work for me (Condor TV) – elkebirmed Oct 12 '15 at 14:08
4

My TV also does that. Usually I just run

xrandr --output LVDS1 --primary --auto --output HDMI1 --auto --same-as LVDS1

This fixes the wrong resolution on the monitor, making it a mirror of my laptop.

I have this command conveniently aliased to something I can remember:

alias xrandr-hdmi-mirror="xrandr --output LVDS1 --primary --auto --output HDMI1 --auto --same-as LVDS1"

This way I just run xrandr-hdmi-mirror whenever I connect my TV.

Of course, you should adjust HDMI1 and/or LVDS1 to your system. Run xrandr to discover which device you should use.


Updated answer

Since you have only one monitor (your TV) try the following:

  1. Discover the output name of your TV. It is probably HDMI1 or VGA1. To do it, run xrandr then search for the word "connected". For example, if you see HDM1 connected, then your TV is HDMI1.

  2. Try doing a xrandr --output HDMI1 --auto. See if the resolution gets okay.

  3. If not, you'll have to do a xrandr --output HDMI1 --mode 1024x768, for example. However, you should replace 1024x768 to a resolution that your TV supports. The output of xrandr will tell you the available ones.

  • Problem with your method is I am ONLY using the TV as a monitor. There isn't anything for me to compare it to or set as the same. – Chaos Sep 21 '14 at 20:15
  • OK, in this case, try the following: (still editing, hit enter too soon) 1. Run xrandr to discover the name assigned to uour monitor. It is probably VGA1 or HDMI1. – thiagowfx Sep 21 '14 at 20:25
  • Alright, whats the next step? – Chaos Sep 21 '14 at 20:27
  • I've updated my original answer. – thiagowfx Sep 21 '14 at 20:30
  • Tried auto and it was the one I was currently on. Then I tried all the resolutions it listed and each one still was cutting off edges. – Chaos Sep 21 '14 at 20:39
3

I had the same problem with my Samsung TV connecting to my laptop via HDMI and found the solution by going to the TV Menu > Picture > Screen Adjustment > chose "screen fit" that fixed it. There you will find other options too but for me the screen fit did the trick and that over scan issue was fixed.

All this time i was thinking it was the display setting on the Ubuntu laptop i needed to fix. Hope This helps other.

  • Thanks, that was my problem too. On my TV, it was under "aspect ratio" > "just scan" – niknah Nov 7 '16 at 22:59
  • Helped me samsung s22c200 – Vadim Jan 16 at 5:32
1

I was having the same problem. The xrandr info in other answers didn't help in my case, but it was good background anyway. I fixed the problem on my screen by resetting the aspect ratio setting back to 1:1. It had somehow been changed to "wide".

  • You changed it on the tv not computer? – Tim Jun 29 '15 at 20:49
0

Samsung TV:

Tools -> Image Size (change from 16:9 to adjust screen).

If you have another TV or monitor you just search for your model in google/youtube with overscan or zoom image mode

0

Switch Your TV-settings to the 4:3 format. Now You see two black blocks left and right beside the desktop margins. If a third of ubuntu's control panel is cut off now, You can be sure of that the problem is not Your TV.

-1

Guys there is simple solution to it using panasonic TV. In the Advanced Settings, turn the overscan off. This fixes the problem

  • This is a duplicate of the top voted answer – stumblebee May 5 '18 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.