1

I haven't found any utopic unicorn ffmeg repositories, so I am trying to install it from https://launchpad.net/~jon-severinsson/+archive/ffmpeg by changing version from utopic to trusty in /etc/apt/sources.list. However, when I do that, I get the following error Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:

ffmpeg :

Depends: libavcodec54 (>= 7:1.2.5~) but 6:9.11-2ubuntu3 is to be installed or

               libavcodec-extra-54 (>= 7:1.2.5~) but it is not going to be 

installed

      Depends: libavdevice53 (>= 7:1.2.5~) but it is not going to be installed

      Depends: libavfilter3 (>= 7:1.2.5~) but it is not going to be installed

      Depends: libavformat54 (>= 7:1.2.5~) but 6:9.11-2ubuntu3 is to be installed

E: Unable to correct problems, you have held broken packages.

I suppose that's because of version difference and not sure, what to do.

Do I have to search for those libraries and add more repositories, or is there are some simple way to do this?

1

I think the Problem is, that Ubuntu is changing/changed from ffmpeg to avconv. One possible solution is that you install ffmpeg from their homepage

  • Thanks! Static build works. I would like to keep this question opened for a while though, if there is a way to install ffmpeg using apt-get with all it's dependencies, since ffmpeg actually was part of larger quest of opencv compiling and it would be much easier if I could not bother with paths to applications and all that stuff – trainset Sep 21 '14 at 19:44
  • Silly me, I can compile ffmpeg from homepage and it will install all the things that I need. Accepting the answer :) – trainset Sep 22 '14 at 0:10
  • there won't be any back mirgration to ffmpeg because as I said Ubuntu changed to avconv. (can't find any officiall information on that) – frog Sep 22 '14 at 16:45
  • Like with oracle java, which was removed a while ago in favour of openjdk, there should be non-oficial repository somewhere, I found one for trusty and was hoping for utopic with all it's dependencies, but I solved it by compiling and installing from their website. – trainset Sep 23 '14 at 17:53
  • @trainset am I right that my answer worked for you? – frog Sep 23 '14 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.