3

When I installed ubuntu 14.04 there were no drivers in the additional drivers dialogue for my graphics card. I installed x-org edgers PPA and used a driver but it causes ubuntu to freeze when using the touchpad. How can I remedy these problems? Also all the research I have done the answers are far too complicated, looking for an easy to understand instructions!

  • Did you install the latest one sudo apt-get install nvidia-340? – Sylvain Pineau Sep 21 '14 at 12:05
  • The 860M is supported by nVidia's proprietary drivers, AFAIK. – amanthethy Sep 21 '14 at 12:09
  • @amanthethy: I agree but not with the version available in the ubuntu repo (331) but should work with the one from the x-org edgers PPA (340). See the release note and supported products (look for GeForce GTX 860M). – Sylvain Pineau Sep 21 '14 at 12:14
  • After I installed the x-org edgers PPA it gave me two options in the additional drivers dialogue. The nouvea driver wouldn't apply and the nvidia one caused my system to freeze with touchpad use. I tried following instructions to install drivers from the nvidia website, but after logging in it only the wallpaper showed, desktop was missing. – uzi3k Sep 21 '14 at 12:15
  • Try, using ctrl+alt+t to bring up a terminal. If you can, type compiz --replace to make sure compiz can bring Unity up properly. – amanthethy Sep 21 '14 at 12:18
3

The 860M card is supported by nVidia's proprietary drivers.

You can install them pretty quickly and easily. It just looks scary.

  1. Download the appropriate driver from nVidia's webpage. It saves a .run file.
  2. Change to console mode with alt+ctrl+F2, log in and then navigate to your Downloads folder with cd ~/Downloads
  3. Type chmod +x NVIDAFILENAMEHERE.run and then press enter
  4. Type sudo service lightdm stop and then hit enter
  5. Type ./NVIDAFILENAMEHERE.run and then press enter
  6. Follow the prompts on screen to install the drivers.
  • It asked me to exit x? – uzi3k Sep 21 '14 at 12:29
  • My bad. Forgot a step. – amanthethy Sep 21 '14 at 12:33
  • After the command sudo service lightdm stop the screen just went black and I was unable to enter further commands. – uzi3k Sep 21 '14 at 13:07
  • If you follow the steps properly, that won't happen. Step 2 being the key step. – amanthethy Sep 22 '14 at 0:17
  • I get an error on the final command saying run as root, so I re ran the command with sudo infront. It decompressed and I accepted the terms. I then get the warning 'The distribution-provided pre-install script failed! Are you sure you want to continue? I selected 'Abort Installation' as I am fairly keen not to have to reinstall again unless I can find an easier way of doing that than complete reinstall and home drive restore with deja dup!! – uzi3k Sep 25 '14 at 21:06
0

I had similar problems to yours, using either 14.04 or 14.10.

I'm currently using Ubuntu 14.10, but I believe the procedure is the same for 14.04:

As Sylvain Pineau suggested, open a terminal (Ctrl+Alt+T) and add the xorg-edgers PPA:

sudo apt-add-repository ppa:xorg-edgers/ppa

Update the packages list:

sudo apt-get update

Then press the Super key (usually the Windows logo on your keyboard), type Additional Drivers and press Enter. You should now have a choice of driver to use:

Additional Drivers screenshot

Select "Using NVIDIA binary driver - version 340.76 from nvidia-340 (open source)", enter your password and press Apply Changes.

Restart your computer and enjoy! You should have access to a new NVIDIA settings tools called "NVIDIA X Server Settings" (press the Super key and type "nvidia" to look for it).

Since I'm using my computer for work, I need better battery life and I don't really need the power of the NVIDIA card so I deactivate it by going in the NVIDIA tool and selecting "Intel (Power Saving Mode)" from the "PRIME Profiles" section.

Hope this helps!

  • not helping. I have those options : three for : Using NVIDIA binary driver - 340.76, 346.59, 349.16 and the last one is (Recommended Driver), and last option is - using X.Org X server -- Nouveau display driver from xserver-org-video -nouveau. From this four I tried only 349 , that is recommended, but this results in black screen instead of login screen. I'm also using this notebook for work – makkasi Apr 19 '15 at 15:10
0

There are two options - One is to use NVIDIA's drivers with NVIDIA Prime Switch. This way you can switch between GPU's "per session". i.e. you have to logout and login to change GPUs. And all apps use the particular GPU selected for that session.

sudo apt-get remove --purge bumblebee* primus nvidia* sudo apt-get install nvidia-346-updates sudo apt-get install nvidia-settings nvidia-prime

Or you can use Bumblebee's optirun to run per-program via NVIDIA.

sudo apt-get remove --purge nvidia-prime sudo apt-get install nvidia-346-updates sudo apt-get install bumblebee bumblebee-nvidia bbswitch-dkms primus

It's recommended to use the nvidia-346-updates or nvidia-352-updates drivers from the edgers repo ppa:xorg-edgers/ppa instead of the ones available from Ubuntu's default repos.

I have written an elaborate blog post detailing both methods http://blog.championswimmer.in/2015/11/using-nvidia-optimus-switchable-graphics-with-gtx-860m-on-ubuntu-15-04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.