My sound levels in alsamixer, e.g. Mic boost are not saved after restarting.

Many people tell to use sudo alsactl store to save those levels, but that has never worked for me in any machine I own.

In fact, using sudo alsactl restore in the terminal after booting does indeed set the levels, but calling that command in /etc/rc.local does not solve the issue. Is Ubuntu resetting these levels somehow during boot?

  • You say store has never worked, yet restore manages to restore the levels? How is that possible?
    – muru
    Sep 21, 2014 at 13:23
  • @muru Maybe something overwrites them later and sets the Mic Boost to zero. But I don't know what could it be.
    – Alicia
    Sep 21, 2014 at 15:38
  • In /etc/rc.local , try to remove sudo to keep only alsactl restore (not tested ). Is your soundcard the first? (if it is the 2nd which means that you must type F6 in alsamixer to select it, then the command is sudo alsactl store 1
    – laugeo
    Sep 21, 2014 at 17:46
  • Strangely, some controls are persisted without even issuing an alsactl store. For instance, Mic is persisted, but Mic Boost is not.
    – Alicia
    Oct 12, 2014 at 19:40
  • With regard to the first suggestion, I was not using sudo in /etc/rc.local since it already runs as root. My card is the first (0 index). I tried specifying the index, just in case, to no effect.
    – Alicia
    Oct 12, 2014 at 19:44


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.