2

I am using Ubuntu 14.04. I have made setup LAMP by going through step by step from a tutorial. For Apache I mean http://localhost all the files are working fine . But when I am doing http://localhost/phpmyadmin it is showing me error like

Not Found
The requested URL /phpmyadmin/index.php was not found on this server
Apache/2.4.7 (Ubuntu) Server at localhost Port 80

I have gone through various blog and tutorials to solve the issue. In a blog it was written to add Include /etc/phpmyadmin/apache.conf in /etc/apache2/apache2.conf. I made like that and when I made

http://localhost/phpmyadmin it showed me the page like a bunch of code. Here is the code

I have made restart apache several times. But the same issue is present. So can someone kindly tell me how to solve this issue?

  • You can just download the zip and put it to server directory, also look at adminer, it's similar to phpmyadmin. – Aiphee Sep 21 '14 at 9:00
  • That code looks like raw PHP. I would run sudo apt-get purge lamp then sudo apt-get install phpmyadmin Let ubuntu do the rest. – Geary Shull Nov 19 '14 at 7:52
9

Try this, changing the directory if necessary. A symbolic link might need to be created.

From the terminal: sudo ln -s /usr/share/phpmyadmin /var/www/html/phpmyadmin

Reload Apache: sudo /etc/init.d/apache2 reload

  • Its not working at all. By doing this when I am using localhost/phpmyadmin then it is showing the bunch of code. – newuser Sep 21 '14 at 15:20
  • If you have used the code I gave above, It should have created a symbolic link in the /var/www/html folder. Did you see it when you went there? What is the installation path of your phpmyadmin? When you enter the code above, what error does it give if any? Reply back answering those question to shed some more light. – user271219 Sep 21 '14 at 15:25
  • I have decided for doing clean remove of LAMP server and re-installing again. It just wasted my one day completely. Can you tell me how to clean remove the lamp and install again? – newuser Sep 21 '14 at 15:41
  • The answer from this article does a very good job at the removal. To reinstall sudo apt-get install lamp-server^ after lamp is installed, do sudo apt-get install libapache2-mod-auth-mysql phpmyadmin this is to install phhmyadmin and the auth. after installing phpmyadmin run the code to create the symbolic link and it should work nicely. – user271219 Sep 21 '14 at 15:48
1

Type the commands below in terminal(Ctrl+Alt+T). It works for me...

sudo ln -s /usr/share/phpmyadmin /var/www/html/phpmyadmin


sudo /etc/init.d/apache2 reload
  • (Y) Worked for me – TechJhola Jan 1 '15 at 9:35
  • what kind of link did ln command made in above directories? Will you describe it? – TechJhola Jan 1 '15 at 9:52
  • It worked for me too – vimal krishna Sep 7 '15 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.