0

I am trying to compile Mirall on my Ubuntu 14.04.1 LTS.

Here is the command I am using:

cmake -DCMAKE_BUILD_TYPE="Debug" ../mirall       -DCSYNC_BUILD_PATH=/home/jnbdz/Projects/ownCloudDesktop/ocsync-build       -DCSYNC_INCLUDE_PATH=/home/jnbdz/Projects/ownCloudDesktop/ocsync/src

Here is the result:

  -- The C compiler identification is GNU 4.8.2

  -- The CXX compiler identification is GNU 4.8.2

  -- Check for working C compiler: /usr/bin/cc

  -- Check for working C compiler: /usr/bin/cc -- works

  -- Detecting C compiler ABI info

  -- Detecting C compiler ABI info - done

  -- Check for working CXX compiler: /usr/bin/c++

  -- Check for working CXX compiler: /usr/bin/c++ -- works

  -- Detecting CXX compiler ABI info

  -- Detecting CXX compiler ABI info - done

  -- Found Qt5 core, checking for further dependencies...

  -- Using Qt 5!

  -- Found PkgConfig: /usr/bin/pkg-config (found version "0.26") 

  -- checking for module 'neon'

  --   found neon, version 0.30.0

  -- Found Neon: /usr/lib/libneon.so  

  -- neon-config executable: /usr/bin/neon-config

  -- libneon has not been compiled with LFS support, rely on OS

  CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):

Could NOT find Qt5Keychain (missing: QTKEYCHAIN_LIBRARY)

  Call Stack (most recent call first):

/usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)

  cmake/modules/FindQt5Keychain.cmake:30 (find_package_handle_standard_args)

  CMakeLists.txt:106 (find_package)



  -- Configuring incomplete, errors occurred!

  See also "/home/jnbdz/Projects/ownCloudDesktop/mirall-build/CMakeFiles/CMakeOutput.log".

So I tried installing manually QT5Keychain. By downloading from this page: http://hr.archive.ubuntu.com/ubuntu/pool/universe/q/qtkeychain/.

These two packages: libqt5keychain0_0.3.0-2_i386.deb, and qt5keychain-dev_0.3.0-2_i386.deb.

Then again it sends me the same error.

I also tried to search:

sudo find / -name qtkeychain.dylib
sudo find / -name qt5keychain.dylib

But did not find anything.

I also tried this:

sudo apt-get install qt5keychain-dev

Result:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
qt5keychain-dev:i386 is already the newest version.
The following packages were automatically installed and are no longer required:
  libgcrypt11-dev libgnutls-dev libgnutlsxx27 libgpg-error-dev libp11-kit-dev
  libtasn1-6-dev
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 119 not upgraded.

So it seems everything is install... So I have no idea why it is still complaining.

1

You should first of all download libqt5keychain and qtkeychain-dev packages in order to resume mirall compilation.

Use the wget command for each of these urls (it depends on your system architecture):

wget http://hr.archive.ubuntu.com/ubuntu/pool/universe/q/qtkeychain/libqt5keychain0_0.3.0-2_amd64.deb  
wget http://hr.archive.ubuntu.com/ubuntu/pool/universe/q/qtkeychain/qtkeychain-dev_0.1.0-1ubuntu1_amd64.deb

Then, install with:

dpkg -i qt5keychain-dev_0.3.0-2_amd64.deb libqt5keychain0_0.3.0-2_amd64.deb
  • I tried and did not work. I was told to try this: -DBUILD_WITH_QT4=On In the cmake. But did not change much. – jnbdz Sep 25 '14 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.