7

This question already has an answer here:

I am on Ubuntu 14.04. 64-bit and I am trying to install linuxband. To do I need to install the package libjack-dev, but when I do so I obtain the following message:

Some packages could not be installed. This may mean that you have requested an 
impossible  situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libjack-dev : Depends: libjack0 (= 1:0.121.3+20120418git75e3e20b-2.1ubuntu1) but it is 
not going to be installed
E: Unable to correct problems, you have held broken packages.

The point is that I do have the other libjack-jackd2 installed for example, but when I run the ./configure for linuxband I get:

checking for JACK_MIDI_NEEDS_NFRAMES... no

Which is the only no in the list. When I run the make, it generates a plethora of undefined references (examples:

src/main/c/linuxband-player.c: In function ‘main’:
src/main/c/linuxband-player.c:768:2: warning: ‘g_thread_init’ is deprecated (declared at
/usr/include/glib-2.0/glib/deprecated/gthread.h:261) [-Wdeprecated-declarations]
g_thread_init(NULL);
^

or later

linuxband-player.c:(.text+0x50b): undefined reference to `jack_transport_query'
linuxband-player.c:(.text+0x586): undefined reference to `jack_transport_query' 
linuxband-player.c:(.text+0x5a1): undefined reference to `jack_last_frame_time'
linuxband-player.c:(.text+0x615): undefined reference to `jack_last_frame_time'
linuxband-player.c:(.text+0x672): undefined reference to `smf_peek_next_event'
linuxband-player.c:(.text+0x6b5): undefined reference to `smf_event_is_metadata

and so on)

until it ends in:

 /tmp/ccrh0o5V.o:remote_control.c:(.text+0xf01): more undefined references to `g_log' follow
collect2: error: ld returned 1 exit status
make: *** [target/linuxband-player] Error 1

Can someone help please?

marked as duplicate by David Foerster, Eric Carvalho, mikewhatever, Eliah Kagan, s3lph Apr 13 '15 at 22:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Well, it's a shame this has been declared as duplicate so I cannot post an answer, because there is a specific answer in terms of jack (and not in terms of apt package management per se). I also had the same problem, but I noticed on packages.ubuntu.com/trusty/libjack-dev this: "Packages providing libjack-dev: libjack-jackd2-dev"; so I just did sudo apt-get install libjack-jackd2-dev instead, and I didn't have the Depends: libjack0 problem anymore. – sdaau Mar 28 '16 at 15:54
7

I had a similar case, where libjack0 will not automatically install because skype:i386 was messing up with it (because Skype has no 64-bit version for Linux).

The solution for me simply was to force it:

sudo apt-get install libjack0

Then it asked me to confirm installation of libjack0 which meant the uninstalling of a few other conflicting programs (including Skype in my specific case). It then did install libjack-dev smoothly (which for me was a requirement for building Audacity).

Not the answer you're looking for? Browse other questions tagged or ask your own question.