2

I bought the Logitech MX800 Wireless Performance combo yesterday. When I plugged it into my machine (Ubuntu 14.04) the keyboard worked but the mouse didn't. I tried to plug the unifying receiver into a Windows machine I have and it worked perfectly both mouse and keyboard.

I found a bunch of info on Google where people had similar problems but none of the solutions work for me. This is one of them: Is Logitech's Unifying receiver supported?

The thing is that the system seems to find and recognize the mouse. If I check in the mouse/pointer settings under settings manager I find the mouse there and activated.

I also installed the program "Solaar" to see if I could solve it with that but with no results. One thing however, is that when I chose to unify in Solaar and turn off the mouse to then turn it on, a notification appears to tell me the status of the keyboard :|

lsusb | grep Logitech:

Bus 002 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver

dmesg | grep Logitech:

[    2.421777] usb 2-1: Manufacturer: Logitech
[    2.667411] usb 2-2: Manufacturer: Logitech
[    2.686752] input: Logitech USB Laser Mouse as /devices/pci0000:00/0000:00:14.0/usb2/2-2/2-2:1.0/0003:046D:C069.0004/input/input2
[    2.686893] hid-generic 0003:046D:C069.0004: input,hidraw0: USB HID v1.10 Mouse [Logitech USB Laser Mouse] on usb-0000:00:14.0-2/input0
[    2.687667] logitech-djreceiver 0003:046D:C52B.0003: hiddev0,hidraw1: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-1/input2
[    2.744741] input: Logitech Unifying Device. Wireless PID:2010 as /devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1:1.2/0003:046D:C52B.0003/0003:046D:C52B.0005/input/input3
[    2.744895] logitech-djdevice 0003:046D:C52B.0005: input,hidraw2: USB HID v1.11 Keyboard [Logitech Unifying Device. Wireless PID:2010] on usb-0000:00:14.0-1:1
[  678.014826] usb 2-1: Manufacturer: Logitech
[  678.021007] logitech-djreceiver 0003:046D:C52B.0008: hiddev0,hidraw1: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-1/input2
[  678.078764] input: Logitech Unifying Device. Wireless PID:2010 as /devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1:1.2/0003:046D:C52B.0008/0003:046D:C52B.0009/input/input10
[  678.078925] logitech-djdevice 0003:046D:C52B.0009: input,hidraw2: USB HID v1.11 Keyboard [Logitech Unifying Device. Wireless PID:2010] on usb-0000:00:14.0-1:1

I've also tried updating the kernel and compiling and running different unifying solutions (which in the end mostly turned out to be just about the same code just remade by different people) but none has worked.

Has anyone experienced similar issues and maybe have a solution for this? Because I'm starting to run out of ideas :(

  • Just to update this thread a little bit. My problem persists and I have done some research in hopes of solving it but without any result. Among the things I have tried are: askubuntu.com/questions/128345/… askubuntu.com/questions/218370/… askubuntu.com/questions/237029/… – jra Oct 10 '14 at 15:28
  • New breakthrough in this case. I removed the keyboard completely and unplugged the receiver. Then I only added the mouse, and it worked! After adding the keyboard as well everything works, but the mouse is super laggy. The receiver is right next to it but it's still super laggy. So the I'm much closer to a solution now, but I still wouldn't consider this as solved. More to come. – jra Oct 14 '14 at 21:12
4

So I finally got everything sorted out. The main problem was that the keyboard got unified first which messed it up for some reason. If I removed everything and unified the mouse first and then the keyboard, everything worked. The reason it didn't work at first when I tried this was because the keyboard didn't get properly removed.

Solution:

1: Install Solaar (for easy management).

2: Remove all unified devices (connect other keyboard and mouse with cable to control from here).

3: Now turn off both mouse and keyboard and unplug the unifier from the machine.

4: Insert the unifier again and choose to unify new device via Solaar.

5: Turn on the mouse.

6: When the mouse is unified properly, turn on the keyboard.

The problem with the lagging was because of two things. The first cause seems to have been that I had the two devices somehow unified three times in Solaar. Fixing this and restarting seems to have solved most of the lagg, but not all. The rest of the lagging issue was resolved by using another USB-plug in the machine. Apparently the unifier draws a lot of power which the front USB-plugs in my Intel NUC couldn't seem to handle.

Hope this solves it for others as well :-)

  • An addition to this answer. Plugging in the extension cable at the back of the NUC and putting the unifier in there instead, removed all my remaining lag. – jra Oct 18 '14 at 19:13
  • My mouse was lagging for like 2 months and I figured it was just getting old, after reading this comment I moved the receiver to the back and the lag seems to be gone completely! Thanks a bunch! – Rosenpin Jan 27 '17 at 12:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.