I have a realtek wifi card which is really messing up the internet connection on my laptop. As per a few launchpad bugs,they have suggested to disable msi and powersave. How do I set the parameters msi, swlps, ips and fwlps? details of the wifi card driver is below.

 modinfo rtl8723be
filename:       /lib/modules/3.16.3-031603-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw.bin
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         PageHe  <page_he@realsil.com.cn>
srcversion:     8630CF9344D90D47240D1FF
alias:          pci:v000010ECd0000B723sv*sd*bc*sc*i*
depends:        rtlwifi,rtl_pci,btcoexist,mac80211
vermagic:       3.16.3-031603-generic SMP mod_unload modversions 
parm:           swlps:bool
parm:           swenc:using hardware crypto (default 0 [hardware])
 (bool)
parm:           ips:using no link power save (default 1 is open)
 (bool)
parm:           fwlps:using linked fw control power save (default 1 is open)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)

parm:           debug:Set debug level (0-5) (default 0) (int)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)

Wireless card

lspci  | grep -i wire
 02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

if I set msi=0 i get the following error

[   18.096063] rtl8723be: unknown parameter 'msi' ignored
  • Could you post how you tried to set msi=0? – user.dz Oct 26 '14 at 17:49
  • 1
    cat /etc/modprobe.d/rtl8723be.conf options rtl8723be fwlps=0 swlps=0 ips=0 #options MSI=1 – Ubuntuser Oct 27 '14 at 4:34

Regarding your question for how to set parameters, you could use something like (=0 meaning disable, =1 meaning enable, and as Sneetsher mentions msi is disabled by default): $ echo "options rtl8723be fwlps=0 ips=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

Regarding your WiFi problem, you could check out my answer to the question My wifi drops the connection after a few minutes realtek8723be

I'm using Ubuntu 14.04 with 14.10 kernel. It does work for me.

~$ sudo modprobe  rtl8723be msi=0
~$ more /sys/module/rtl8723be/parameters/msi 
N
~$ sudo modprobe -r rtl8723be
~$ sudo modprobe  rtl8723be msi=1
~$ more /sys/module/rtl8723be/parameters/msi 
Y

Same module version:

~$ modinfo rtl8723be
filename:       /lib/modules/3.16.0-23-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw.bin
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         PageHe  <page_he@realsil.com.cn>
srcversion:     C94095C986767A931B924EF

Default is 0 for msi so no need for it, but you should for ips=0 fwlps=0

Try with both modprobe or insmod.

Before you start, you will need to install sysfsutils:

sudo apt-get update
sudo apt-get install sysfsutils

First, to show the options that are currently in use and the existing parameters, run the following command:

sudo systool -a -v -m rtl8723be | grep -A8 "Parameters:"

Under "Parameters:", you will see the available options and the existing parameters. Here is an example of that section:

  Parameters:
    debug               = "1"
    disable_watchdog    = "N"
    fwlps               = "Y"
    ips                 = "Y"
    msi                 = "Y"
    swenc               = "N"
    swlps               = "N"

It appears that the msi option can be set to Y or N.

To set msi to off, you should run the following commands:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be msi=N

Now, verify the change:

sudo systool -a -v -m rtl8723be | grep -A8 "Parameters:"

The output should now look like this:

  Parameters:
    debug               = "1"
    disable_watchdog    = "N"
    fwlps               = "Y"
    ips                 = "Y"
    msi                 = "N"
    swenc               = "N"
    swlps               = "N"

To make this change permanent, you should create a file /etc/modprobe.d/rtl8723be.conf. Run the following command:

sudo nano /etc/modprobe.d/rtl8723be.conf

Now, copy and paste the following into the file:

options rtl8723be debug=1
options rtl8723be disable_watchdog=N
options rtl8723be fwlps=Y
options rtl8723be ips=Y
options rtl8723be msi=N
options rtl8723be swenc=N
options rtl8723be swlps=N

Press CTRL + o and then press ENTER to save the file. Press CTRL + x to exit nano.

Now you can make changes to this file to apply your desired settings. After you make changes to the file, run the following commands to apply the changes:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be
  • 1
    There is a new parameter in new versions "ant_sel" that is very useful for 1 antenna laptops. – Pilot6 Feb 29 '16 at 23:07

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.