2

I'm preseeding a 14.04 Trusty install, on a machine which requires a driver fix from the 3.16 kernel, which is the one which goes with 14.10 Utopic. The easiest way to get this kernel is to install the corresponding hardware enablement stack:

http://www.ubuntuupdates.org/package/canonical_kernel_team/trusty/main/base/linux-generic-lts-utopic

When I add the PPA and install the package after installation, it works out fine. However, when I add linux-generic-lts-utopic to the pkgsel/include line in my preseed, I get a kernel panic on first boot into the installed system (happens in Parallels and on the actual hardware). It turns out that I have to use the GRUB menu to first boot the default 3.13 kernel, and then run:

sudo update-initramfs -c -k 3.16.0-17-generic
sudo update-grub

After doing this, it can boot 3.16 just fine.

This seems super janky. Is this a regression in the hardware enablement stack, or a problem with the installer, or something missing from preseed?

Thanks.

  • What is your preseed file like? Did you try adding an update-initramfs command as a late command? – muru Sep 20 '14 at 1:14
  • I have done the late-command, and that works, but it's a hack and should be unnecessary if the package and/or installer were configured correctly. – mikepurvis Sep 20 '14 at 3:18
  • There's an option called base-installer/kernel/image for selecting the kernel to be installed. Tried that? – muru Sep 20 '14 at 3:34
  • I tried image and override-image. Neither had any effect— the package doesn't get installed. I tried also installing the package via pkgsel, but then I just get the kernel panic. – mikepurvis Sep 20 '14 at 13:32
  • Note that update-initramfs -c -k all in the late_command does not work. You have to call out the exact version to generate for. – mikepurvis Sep 30 '14 at 18:52
3

For a generalized version of the hack, do:

update-initramfs -c -k $(ls /lib/modules -1 | tail -1)
update-grub

This can be done directly from the late_command, or via a script that the late command invokes.

1

Have you tried using the lts-utopic d-i images linked from http://cdimage.ubuntu.com/netboot/trusty/ rather than trying to hack it up in a preseed from a d-i booting with 3.13?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.