17

I have a HP pavillion g6, running Xubuntu 14.04 64-bit. I have 3 USB ports. For some reason, 2 of them stopped working this morning.

I have xserver-xorg-input-all installed, followed the instructions here which didn't work. My laptop is updated and upgraded to the latest version. lsusb outputs

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0a5c:21e3 Broadcom Corp. HP Portable Valentine
Bus 001 Device 005: ID 2188:0ae1  
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I tried on Manjaro live cd, and all ports are working. Isn't there an error log for usb ports so i can see whats going on?

My /var/log/dpkg.log and /var/log/apt/history.log are here

16
  • 3
    Boot from a live DVD/USB and test the 2 USB ports and edit your question ruling out hardware issues.
    – user68186
    Sep 19, 2014 at 17:37
  • @user68186 I tried on Manjaro live cd, all ports are working
    – Lynob
    Sep 19, 2014 at 18:51
  • 1
    @KarlRichter i don't have that right now, but why would i even need that? it's clearly a software issue and not a hardware issue
    – Lynob
    Sep 19, 2014 at 20:03
  • 1
    @KarlRichter it's not an ubuntu issue, i have been using xubuntu 14.04 since beta days and only today the ports stopped working
    – Lynob
    Sep 19, 2014 at 20:08
  • 1
    @KarlRichter i mean if i use from live cd , it will work like it did before and i done it before, i update my system many times since i installed it and done many changes to it, but the ubuntu image will work like it once did - Lets assume that you are right and it was an ubuntu issue. does it change a thing? it doesn't, still a software issue that needs to be fixed, my hardware is fine, ubuntu is an OS, an OS is nothing but bunch of software, therefore the method to fix this error is still the same practically
    – Lynob
    Sep 19, 2014 at 20:16

4 Answers 4

26

Here I got my USB3 ports not working after a while: only a restart fixes the problem.

After some research, I've found that a lot of USB3 ports presents a power management problem In a lot of different hardwares and OSs. You can find people reporting this kind of problem on Windows, Linux, etc.

So, I've disabled USB power management, and now everything is fine.

1. Disabling USB Power Management

For Ubuntu, usbcore module is compiled in the kernel, so we need to change the kernel boot parameters.

Edit the /etc/default/grub file and change the GRUB_CMDLINE_LINUX_DEFAULT line to add the usbcore.autosuspend=-1 option:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"

Note that quit splash were options already present. So keep other options you have too.

Save file and close.

2. Update grub

After save the file, update grub:

sudo update-grub

And reboot.

3. Check autosuspend after reboot

After reboot, check autosuspend value:

cat /sys/module/usbcore/parameters/autosuspend

And it should display -1.

11
  • 1
    I reinstalled so i cant test it, i opened a bounty for a week and no one answered so i decided to reinstall but thanks for the solution, if i it ever happen to me again, i know where to look
    – Lynob
    Oct 10, 2014 at 15:33
  • This does not work for me in 15.10.. autosuspend value remains 2. Did something change in 15.10.? Apr 12, 2016 at 13:43
  • @JonasAdler, in a quick look, in the latest kernel versions, the param to change is autosuspend_delay_ms, but I didn't try yet. Let me know if this works and I can update the answer. Apr 12, 2016 at 13:53
  • @RaelGugelminCunha so "quiet splash usbcore.autosuspend_delay_ms=-1" ? Apr 12, 2016 at 13:58
  • 1
    @RaelGugelminCunha thank! The setting is now in place, let's see if it works. I will report back. Apr 12, 2016 at 14:05
3

I had a similar problem and http://www.ubuntugeek.com/how-to-fix-usb-stops-working-problem-in-ubuntu.html lists another way to fix this

This method also edits the grub but instead of modifying GRUB_CMDLINE_LINUX_DEFAULT it modifies GRUB_CMDLINE_LINUX="".

Steps:

  1. Open terminal
  2. Type gksudo gedit /etc/default/grub in terminal and press enter
  3. Find the line GRUB_CMDLINE_LINUX=""
  4. Modify the line to read GRUB_CMDLINE_LINUX="acpi=force irqpoll"
  5. After that, update the bootloader via terminal by typing sudo update-grub and pressing enter
  6. Restart your system

This method is the same as given in the link above and it worked for me.

I use Ubuntu Desktop 14.04 64 bit.

1

This is simple solution you can try this:

first execute below command in terminal:

sudo dpkg-reconfigure xserver-xorg

after, reboot your computer and it's worked for me!

0

Check if External USB is enabled in BIOS of yours computer. In my case, it somehow changed state.

This is purely dependent on your system, however this might solve the issue like it was for me.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.