I am using Netbeans IDE 8.0 in my system 14.04 LTS.

I have installed Python plugin in Netbeans 8.0 by following this link.

And also I have download python-3.4.1.tgz from this link and installed it as following in terminal,

tar -xvf Python-3.4.1.tgz
cd Python-3.4.1/
sudo make install

I got result at last as,

arul@arul-Aspire-5740:~/Python-3.4.1$ ./python
Python 3.4.1 (default, Sep 19 2014, 17:14:45) 
[GCC 4.8.2] on linux
Type "help", "copyright", "credits" or "license" for more information.

I confirmed by using following command in terminal

python3 -V

got response as,

Python 3.4.1

But when I click Auto Detect in Python Platform Manager (Netbeans IDE 8.0.1) am am not getting 3.4.1 in the list(Shown below).

enter image description here

How to solve it ?


I tried,

 arul@arul-Aspire-5740:~$ sudo find / -type f -executable -iname 'python*' -exec file -i '{}' \; | awk -F: '/x-executable; charset=binary/ {print $1}' | xargs readlink -f | sort -u | xargs -I % sh -c 'echo -n "%: "; % -V'

And I got result as,

[sudo] password for arul: 
/home/arul/Python-3.4.1/python: Python 3.4.1
/usr/bin/python2.7: Python 2.7.6
/usr/bin/python3.4: Python 3.4.0
/usr/bin/python3.4m: Python 3.4.0
/usr/local/bin/python3.4: Python 3.4.1
/usr/local/bin/python3.4m: Python 3.4.1

It's showing 3.4.1 but why not Netbeans detecting?

  • @IAnsari How it is duplicate ?
    – A J
    Sep 20 '14 at 5:08
  • How have you installed 3.4.1?
    – muru
    Sep 20 '14 at 5:27
  • Could you execute this command sudo find / -type f -executable -iname 'python*' -exec file -i '{}' \; | awk -F: '/x-executable; charset=binary/ {print $1}' | xargs readlink -f | sort -u | xargs -I % sh -c 'echo -n "%: "; % -V' and add output to answer. It will show all python installed. Here is source
    – c0rp
    Sep 20 '14 at 5:31
  • @muru I have updated in question that how I installed python 3.4.1, please take a look..
    – A J
    Sep 20 '14 at 8:41
  • 1
    @ARUL why don't you execute command that I mentioned? May be you only need to create symlink to your python 3.4.1 directory
    – c0rp
    Sep 20 '14 at 10:27

Select "New" there in the "Python Platform Manager".
Then It will open a dialog box.
Navigate to /usr/local/bin and select python3.4.
AT least that works on Windows.

If the dialog box does not appear, then in the command field of the new profile type


and in Console Command type the same thing. In platform name type Python 3.4.1 That will fix your problem.

Don't forget to award the bounty!

  • This worked for me on Ubuntu after I changed all instances of /usr/local/bin to just /usr/bin Sep 29 '15 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.