I installed Ubuntu 11.04 on 2 laptops today. One of a friend, and one of my own. Both have NVidia graphics cards.

This went the same on both computers. When you login the first time you get a message wich is basically telling you to install the NVidia drivers.

However, when I restarted after installing the new driver on my friend's laptop, Unity just worked.

When I installed the drivers on my laptop, and rebooted, it just booted straight back into the Ubuntu Classic desktop environment.

In the sessions list at the login screen, there are the following items: Ubuntu, Ubuntu Classic, Ubuntu Classic (no effects), User defined, Recovery console. I haven't touched this setting, as it seems to me that Ubuntu should be correct.
Appart from that when I login I still get the Ubuntu Classic environment (without the message telling me that Unity couldn't be started) When I run compiz --replace manually, I get the Unity interface... but it instantly freezes.

So why doesn't it start the Unity interface? My graphics card is an Nvidia Quadro NVS 110M, wich has always worked fluently with Compiz Fusion.

  • have you tried reinstalling unity; it may 'repair' your ubuntu session? – thomasmichaelwallace Jul 11 '11 at 7:53
  • As to be expected, this did not solve the problem. Neither did updating Unity, wich I didn't do before because I'm on vacation and the wireless internet is.... let's just say it's crap. – RobinJ Jul 11 '11 at 10:39

A similar AU Question with your Graphics Card is described here.

I would suggest follow the same advice - go to your Hardware Drivers window. Deactivate the nvidia-current driver and try installing the nvidia-173 driver.

  • Well, that's one step in the right direction... Now at least Unity works when I run compiz --replace. However, the Gnome Panels are still there as well. So it would be nice if Unity would automatically start on login (session: Ubuntu), and the Gnome Panels would go away. – RobinJ Jul 13 '11 at 9:36
  • By the way, compiz --replace does seem to return an awful lot of errors. Don't know if it will help you but here's the output of compiz --replace --debug: pastebin.com/sN2NShw8 – RobinJ Jul 13 '11 at 9:46
  • try installing/reinstalling unity-place-applications and unity-place-files packages – fossfreedom Jul 13 '11 at 10:01
  • I installed all updates (appart from the kernel updates), rebooted, reinstalled unity-place-applications and unity-place-files, rebooted again, and it went straight into the classic Ubuntu desktop again... Running compiz --replace also still gives me a working Unity interface... but on top of my Gnome panels... I believe there was something in gconf to not make the panel load anymore (wich I used with Avant Window Navigator), but I can't find it anymore. Also, uninstalling gnome-panel doesn't seem to me like it's a very good thing to do. – RobinJ Jul 13 '11 at 12:18
  • 1
    I've already fuxed the problem of the Unity interface starting on top of the Gnome Panel myself. I added compiz --replace to the startup applications to start Unity, and made sure that the Gnome Panel was unable to start.... by removing /usr/bin/gnome-panel xD Not really a friendly way to do it, but it works :p I'm going to mark your answer as accepted because you seem to have identified the problem correctly. – RobinJ Jul 14 '11 at 7:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.