I have a problem with Huawei E3272 modem. Ubuntu 14.04 does not detect it as a mobile broadband modem. If I put my SIM card into my old modem(E3131) everything works, E3272 is just not detected. I have checked lsusb, and here I can see the system detects it as 12d1:14fe Huawei Technologies Co., Ltd. but I cannot choose it in my Network Connections.

I tried adding usbserial vendor=0x12d1 product=0x14fe in /etc/modules, but it did not change anything. The same goes for adding

# Huawei E3272 ATTR{idVendor}=="12d1", ATTR{idProduct}=="157c", RUN +="usb_modeswitch '%b/%k'"

in /lib/udev/rules.d/40-usb_modeswitch.rules. I also tried installing Modem Manager, but it did not help.

Have you got any idea what could I do, so my system would detect my new modem? I would like to be able to use LTE. :)


The same changes is applicable, and needed, in Ubuntu 14.10 as well.

So open the Terminal and copy the following:

sudo gedit /lib/udev/rules.d/40-usb_modeswitch.rules

Add the following lines:

# Huawei E3272 
ATTR{idVendor}=="12d1", ATTR{idProduct}=="157c", RUN +="usb_modeswitch '%b/%k'" 

Save the file, close all open programs and restart the system. Now reinsert your modem. There will be no message or confirmation, but the connection will appear in your panel as it would if you would insert an ethernet cable.

  • This worked for me only after I restarted the system. Hence, edited answer to add the restart bit. No harm in restarting the system, even if it works for some. – Sri Jul 17 '15 at 10:11
  • It should suffice to sudo service udev restart. – avip Jan 28 '19 at 11:29

This worked for my E353/E3131 HiLink Modem on Ubuntu 16.04LTS:

  • Find the modem idvendor and idProduct using lsusb.

  • Open the Terminal and run the following:

    sudo gedit /lib/udev/rules.d/40-usb_modeswitch.rules

This will open gedit editor. There, add the following lines:

# Huawei E353/E3131
ATTR{idVendor}=="12d1", ATTR{idProduct}=="1f01", RUN +="usb_modeswitch '%b/%k'" 
  • Save and you are done.

Nevermind, I deleted the mentioned line in /etc/modules and Ubuntu detected my modem. If you have similar problem just add your modem using information from lsusb in /lib/udev/rules.d/40-usb_modeswitch.rules , it works like a charm. :)


The rules for the initial codes must be like this:

Huawei E3272 ATTR{idVendor}=="12d1", ATTR{idProduct}=="14fe", RUN +="usb_modeswitch...

See the usb_modeswitc_data package for details. The latest version for 14.04 contains rules for this modem. You may update it, it has no dependences.



# HUAWEI Mobile WiFi E5776
ATTR{idVendor}=="12d1", ATTR{idProduct}=="1506", RUN +="usb_modeswitch '%b/%k'" 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.