0

Yesterday I installed Windows 7 (on /dev/sdb1) and Windows 8.1 (on /dev/sdb2).

"Of course", my existing Ubuntu 14.04 (on /dev/sdb3) was therefore rendered unbootable. I fixed this with the Boot Repair utility via Ubuntu 14.04 Live USB.

However, something odd is going on:

  1. I ran Boot Repair after I installed Windows 7, which nicely made Ubuntu and Windows 7 show up in the grub menu.
  2. I ran Boot Repair again after I installed Windows 8.1, which nicely made Ubuntu and Windows 8 appear in the grub menu...But...where has Windows 7 gone?

So I ran Boot Repair again, to no avail. I manually ran

$ sudo update-grub

which resulted in

Found linux image: /boot/vmlinuz-3.13.0-35-generic 
Found initrd image: /boot/initrd.img-3.13.0-35-generic 
Found linux image: /boot/vmlinuz-3.13.0-34-generic 
Found initrd image: /boot/initrd.img-3.13.0-34-generic 
Found linux image: /boot/vmlinuz-3.13.0-24-generic 
Found initrd image: /boot/initrd.img-3.13.0-24-generic 
Found memtest86+ image: /boot/memtest86+.elf 
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 8 (loader) on /dev/sdb1
done.

weird - It shows Windows 8 on /dev/sdb1, where Windows 7 is installed.

Also:

$ sudo os-prober 
/dev/sdb1:Windows 8 (loader):Windows:chain
$

...no Ubuntu? No Windows 7?

I also ran Boot Info Script:

               Boot Info Script 0.61      [1 April 2012]

============================= Boot Info Summary: ===============================

=> Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 1 of the same hard drive for core.img. core.img is at this location and looks in partition 112 for .
=> Grub2 (v1.99) is installed in the MBR of /dev/sdb and looks at sector 1 of the same hard drive for core.img. core.img is at this location and looks in partition 112 for .
=> No boot loader is installed in the MBR of /dev/sdc.

sda1:


File system:       swap
Boot sector type:  -
Boot sector info:

sda2:


File system:       Extended Partition
Boot sector type:  -
Boot sector info:

sda5:


File system:
Boot sector type:  -
Boot sector info:
Mounting failed:   mount: unknown filesystem type ''

sdb1:


File system:       ntfs
Boot sector type:  Windows Vista/7: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  Windows 7
Boot files:        /bootmgr /Boot/BCD /Windows/System32/winload.exe

sdb2:


File system:       ntfs
Boot sector type:  Windows Vista/7: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:
Boot files:        /bootmgr /Windows/System32/winload.exe

sdb3:


File system:       ext4
Boot sector type:  -
Boot sector info:
Operating System:  Ubuntu 14.04.1 LTS
Boot files:        /boot/grub/grub.cfg /etc/fstab

sdb4:


File system:       ext2
Boot sector type:  -
Boot sector info:
Operating System:
Boot files:

sdc1:


File system:       ext4
Boot sector type:  -
Boot sector info:
Operating System:
Boot files:

sdc2:


File system:       ntfs
Boot sector type:  Windows Vista/7: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:
Boot files:

-- snip because the rest is personal :) --

Boot flags are on /dev/sda1 and /dev/sdb1.

So everything seems in order, but Grub simply doesn't recognize the two Windows correctly...What's going on?

(For completeness, /dev/sda is a broken and unused SDD which I'm experimenting with.)

1

To dual-booting between Windows 8 and Windows 7 you must install the older OS first, make room for the second OS, and then install the newer OS.

Once Windows 8 is installed, you’ll find a new boot menu that appears when the PC starts up.

You must use this menu to pick between the Microsoft OSes installed on the PC.

  • So you're saying Grub cannot distinguish between Windows 7 and Windows 8? – Rody Oldenhuis Sep 19 '14 at 11:48
  • Windows 8, takes command of the computer overrides the Windows 7, which can only be boot from the menu of Windows 8, and Grub is limited to power so that you can boot to do this, Windows 8. – kyodake Sep 19 '14 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.