Today after finishing the update i got update information

enter image description here

I have tried clicking on run action now, but by that nothing happens only terminal opens up and then after minute it automatically closes down.

NOTE:I have seen question related to this, but not sure to use solution as there was pepflashplugin installer while in my case it is only flashplugin installer

  • see this answer.askubuntu.com/a/319284/146791
    – g_p
    Sep 19, 2014 at 14:21
  • @G_P I pasted the location of file but it is not working :(
    – Freddy
    Sep 19, 2014 at 16:37
  • 1
    Is that Coldplay on the wallpaper?
    – mwfearnley
    Jan 11, 2017 at 13:16
  • 1
    @mwfearnley Yes :)
    – Freddy
    Jan 11, 2017 at 14:25

5 Answers 5


I had the same problem and have fixed it with the following two steps from the command line:

  1. Removing flashplugin-installer completely with the following command

    sudo apt-get remove --purge flashplugin-installer
  2. Re-installing flashplugin-installer again with the command

    sudo apt-get install flashplugin-installer
  • I tried the purge command but I get this error : E: Unable to locate package falshplugin-installer. And if I try the apt-get install or even the apt-get upgrade commands, the terminal says that flashplugin-installer is the latest version!
    – SY_13
    Aug 16, 2015 at 7:49
  • What does apt-cache policy flashplugin-installer return? Aug 16, 2015 at 9:33
  • 1
    I just realised I misspelled the package name. Sorry for wasting your time.
    – SY_13
    Aug 16, 2015 at 11:20
  • This seems to fix things for me, but only temporarily. I keep having to run it maybe once every two to three weeks (with little changing in between)....
    – user638851
    Jan 18, 2017 at 18:55

Another command to force the download to be reattempted:

sudo pkexec /usr/lib/update-notifier/package-data-downloader

I just got this to work in 16.04. This way you don't have to uninstall/reinstall the package. It's the same thing that would happen if you click the "run this action now" button in the GUI.

  • 16.04 here too, if I click the "run this action now" button it fails again. Ridiculous.
    – Csaba Toth
    Dec 16, 2016 at 16:47

Running sudo pkexec /usr/lib/update-notifier/package-data-downloader I received the following error (links obfuscated due to ask policy):

flashplugin-installer: processing...
flashplugin-installer: downloading _http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20161213.1.orig.tar.gz
Err:1 _http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20161213.1.orig.tar.gz
  Could not open file /var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20161213.1.orig.tar.gz - open (2: No such file or directory) [IP: 80]
E: Failed to fetch _http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20161213.1.orig.tar.gz  Could not open file /var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20161213.1.orig.tar.gz - open (2: No such file or directory) [IP: 80]

E: Download Failed

I manually downloaded the file from the URL specified, created a new 'partial' directory in /var/lib/update-notifier/package-data-downloads, moved the download to there and then ran the sudo pkexec /usr/lib/update-notifier/package-data-downloader command again. Which I think appeared to work (Ubuntu 16.04)


I had the same problem, and instead of fixing it with the GUI, I simply did sudo apt-get remove flashplugin-installer and sudo apt-get install flashplugin-installer from Terminal. The problem was that my internet connection was unstable, but after doing this a couple times I got the entire file downloaded and installed.


Per RNA's advice in another post:

sudo rm /var/lib/update-notifier/user.d/data-downloads-failed

fixed on 14.04.

I removed this file in 12.04 LTS, no more error message on bootup, videos play just fine!

Correction: next day error message came back, tried the purge method and re-installed flashplugin, error message appeared immediately.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .