1

Since a few days ago the sound of my headphones no longer works. I have tried the headphones over via Windows and then they do work (same computer, dual boot). I have already tried the following:

but none of these methods worked for me. The sound does work from the normal built-in speakers.

Anybody know a fix?

Here is the output for

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh

http://www.alsa-project.org/db/?f=028ff6475c1ce6661119cb4f3a0dd6cc60af86ba

2

You can check this points:

  1. Windows problem: Some users have reported that you must really "shutdown" pc from Windows8 , just "reboot" cause audio problems. Also, "fastboot" must be disabled in the bios.
  2. Pulseaudio problem: in the "sound parameters" output tab, you should see device automatically changing from speaker to headphone when you plug a jack . As Pulseaudio stores independent level for each state, it could be bad just for headphone .
    You can also run this command a terminal to reset pulseaudio config:
    rm -r ~/.config/pulse; pulseaudio -k

  3. Alsa setting problem: Do you see "headphones" fader when you launch alsamixer in a terminal (eventually press F6 function key to select your main soundcard which is the "not hdmi" one).
    The fader must be unmuted (check toggle mute by pressing "m" key when the headphone fader is selected via left/right arrow keys). Set fader level with up/down keys.

Finally, a software update solved the problem

If nothing works, run "Alsa-info" to show your audio config (someone can have an idea) : copy the following command in a terminal , choose "upload" option when asked ("tab" key to select it) an post url printed at the end.
wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh

8
  • I don't use windows 8 but windows 7 so it cannot be 1. I have tried 2 and 3 but neither worked. Can you see what it is from the alsa project page? – Thijser Sep 19 '14 at 18:21
  • Run the alsa-info, post the result url, it will give soundcard codec name and possible tweak in alsa-base.conf (by adding options snd-hda-intel model=xxxx ) – laugeo Sep 19 '14 at 19:18
  • I have posted the info in the OP – Thijser Sep 19 '14 at 19:23
  • From alsainfo, Master and pcm faders are now muted : use alsamixer :you will see "mm" under the 2 faders: scroll to the faders ,press "m" to unmute them so that "mm" is "00" – laugeo Sep 19 '14 at 20:25
  • Also test changing "automute" in alsamixer to have "speaker " and not "speaker line out", test also "off" – laugeo Sep 20 '14 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.