3

I tried to install MySQL Workbench 6.1.7 on Ubuntu 14.04 after installing Mysql 5.6 library, but get the following: error:

Package dependencies cannot be resolved

This error could be caused by required additional software packages which are missing or not installed. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

The following packages have unmet dependencies:

mysql-workbench:

  • Depends: libgcc1 (>= 1:4.1.1) but 1:4.9.1-0ubuntu1 is to be installed
  • Depends: libgtkmm-2.4-1c2a (>= 1:2.24.0) but 1:2.24.4-1ubuntu1 is to be installed
  • Depends: libpcrecpp0 (>= 7.7) but 1:8.31-2ubuntu2 is to be installed
  • Depends: python:any (>= 2.7.1-0ubuntu2) but it is a virtual package
  • Depends: mysql-workbench-data (= 6.0.8+dfsg-2) but 6.0.8+dfsg-2 is to be installed

According to this bug, there has been an error before but should being solved with the MySQL-Workbench 6.1.7 +

Fixed as of the upcoming MySQL Workbench 6.1.7 release, and here's the change-log entry

On Ubuntu 14, the dependency check was updated to allow any of mysql-client, mysql-client-5.6 or mysql-community-client client libraries. Previously, the dependency check could fail.


I have tried to install the workbench vie Software-Center and also tried the version from mysql.com

if i grep mysql-client i get the following output

ii  mysql-client-5.6        5.6.19-0ubuntu0.14.04.1   amd64   MySQL database client binaries

ii  mysql-client-core-5.6   5.6.19-0ubuntu0.14.04.1   amd64   MySQL database core client binaries

For me it seems that the bug is not solved, or that there is maybe a problem with the mysql version 5.6.19 !?

Or could it be that another package dependency occurs this problem?

Any suggestion or workaround to get the workbench running on mysql 5.6.19 would be great!


UPDATE

I couldn't figure out why the installation of MySQL Workbench 6.1.7 does not work with mysql 5.6.19 , but with the latest Workbench Development Release [Version 6.2.2 rc] everything works fine.

  • Did you get solution for this? – Abdullah Qayum Nov 12 '14 at 12:34
  • Nope. I just installed the latest development release and that version works for me. Also workbench 6.* is now officially released and should work. I just did a regular update without any problems. dev.mysql.com/downloads/workbench – timausk Nov 14 '14 at 9:56
0

Install gcc and python in your machine and try again

sudo apt-get install -y gcc python2.7

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.